# Table of Contents

## Table of Contents

- Introduction ................................................................. 5
  - About this manual ....................................................... 5
  - Conventions used in this Manual ................................. 5
  - Welcome to NiceForm ................................................... 5
- Setting up the Application ............................................. 7
  - User Interface .............................................................. 7
    - Basic and Advanced User Interface ............................. 7
    - Keyboard Shortcuts .................................................... 7
    - Status bar ...................................................................... 8
    - Toolbars ....................................................................... 9
  - Form Security ............................................................. 9
    - Locking Form .............................................................. 9
- Designing Forms ........................................................... 10
  - Using Toolbars .......................................................... 10
  - Using Database Toolbar ............................................... 10
  - Using Standard Toolbar ............................................... 10
  - Using Text Toolbar ...................................................... 11
  - Using Toolbox ............................................................ 12
  - Using Transformations Toolbar .................................... 12
  - Using Variable Toolbar ............................................... 13
- Working with Objects ..................................................... 14
  - Working with Buttons .................................................. 14
  - Defining Actions .......................................................... 14
    - Browse for File or Folder ............................................ 14
    - Close Label ............................................................... 15
    - Define Printer Settings .............................................. 15
    - Execute Script .......................................................... 15
    - Execute SQL Statement .............................................. 16
    - For Every Label ........................................................ 17
    - For Every Record in a Table ....................................... 18
    - For Loop ................................................................. 18
    - Import Data Into Database ....................................... 18
    - Load Variable Data .................................................... 19
    - Move Focus to Object ............................................... 19
    - Open Another Form .................................................. 20
    - Open Document/Program ......................................... 20
    - Open Label ............................................................... 21
    - Print Label ............................................................... 21
    - Read Data from Serial Port ....................................... 22
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Refresh Database</td>
<td>23</td>
</tr>
<tr>
<td>Refresh Previews</td>
<td>23</td>
</tr>
<tr>
<td>Run Command File</td>
<td>23</td>
</tr>
<tr>
<td>Save Variable Data</td>
<td>24</td>
</tr>
<tr>
<td>Select Variables</td>
<td>24</td>
</tr>
<tr>
<td>Send Custom Commands</td>
<td>24</td>
</tr>
<tr>
<td>Send Data to TCP/IP</td>
<td>25</td>
</tr>
<tr>
<td>Set Printer</td>
<td>25</td>
</tr>
<tr>
<td>Set Variable</td>
<td>25</td>
</tr>
<tr>
<td>View Log File</td>
<td>26</td>
</tr>
<tr>
<td>Verify License</td>
<td>26</td>
</tr>
<tr>
<td>Write Data to Serial Port</td>
<td>26</td>
</tr>
<tr>
<td>Quit</td>
<td>27</td>
</tr>
<tr>
<td>Creating the Button</td>
<td>27</td>
</tr>
<tr>
<td>Working with Button Group</td>
<td>28</td>
</tr>
<tr>
<td>Creating the Button Group</td>
<td>28</td>
</tr>
<tr>
<td>Working with Check Boxes</td>
<td>28</td>
</tr>
<tr>
<td>Creating the Check Box</td>
<td>28</td>
</tr>
<tr>
<td>Working with Combo Boxes</td>
<td>29</td>
</tr>
<tr>
<td>Creating the Combo Box</td>
<td>29</td>
</tr>
<tr>
<td>Working with Database Navigator</td>
<td>30</td>
</tr>
<tr>
<td>Creating the Database Navigator</td>
<td>30</td>
</tr>
<tr>
<td>Working with the Database Navigator</td>
<td>30</td>
</tr>
<tr>
<td>Working with Database Search</td>
<td>31</td>
</tr>
<tr>
<td>Creating the Database Search</td>
<td>31</td>
</tr>
<tr>
<td>Working with the Database Search</td>
<td>31</td>
</tr>
<tr>
<td>Working with Edit Fields</td>
<td>32</td>
</tr>
<tr>
<td>Creating the Edit Field</td>
<td>32</td>
</tr>
<tr>
<td>Working with Frame Objects</td>
<td>32</td>
</tr>
<tr>
<td>Creating the Frame Object</td>
<td>32</td>
</tr>
<tr>
<td>Working with List Boxes</td>
<td>33</td>
</tr>
<tr>
<td>Creating the List Box</td>
<td>33</td>
</tr>
<tr>
<td>Working with Memo Fields</td>
<td>34</td>
</tr>
<tr>
<td>Creating the Memo Field</td>
<td>34</td>
</tr>
<tr>
<td>Working with Pictures</td>
<td>34</td>
</tr>
<tr>
<td>Creating the Picture Object</td>
<td>34</td>
</tr>
<tr>
<td>Working with Previews</td>
<td>35</td>
</tr>
<tr>
<td>Creating the Preview</td>
<td>35</td>
</tr>
<tr>
<td>Working with Radio Groups</td>
<td>35</td>
</tr>
<tr>
<td>Creating the Radio Group</td>
<td>35</td>
</tr>
<tr>
<td>Working with Tables</td>
<td>36</td>
</tr>
<tr>
<td>Create the Table Element</td>
<td>36</td>
</tr>
<tr>
<td>Formatting Table Object</td>
<td>36</td>
</tr>
<tr>
<td>Linking Fields with Variables</td>
<td>37</td>
</tr>
<tr>
<td>Using Master - Detail Connection</td>
<td>37</td>
</tr>
<tr>
<td>Working with Text Objects</td>
<td>38</td>
</tr>
<tr>
<td>Creating the Text Object</td>
<td>38</td>
</tr>
<tr>
<td>Working with Variable Prompts</td>
<td>39</td>
</tr>
<tr>
<td>Working with the Variable Prompt</td>
<td>39</td>
</tr>
<tr>
<td>Aligning Objects on the Form</td>
<td>39</td>
</tr>
</tbody>
</table>
Table of Contents

Moving and Resizing Objects ................................................................. 39
Selecting Objects .................................................................................. 40
Working with Variable Data ................................................................. 40
Contents Providers ................................................................................ 40
Working with Databases ....................................................................... 41
Database Wizard ................................................................................... 41
Database Wizard: Starting ................................................................. 42
Database Wizard: Selecting the Database File ..................................... 43
Database Wizard: Field Usage ............................................................ 44
Database Wizard: Select Fields ........................................................... 45
Database Wizard: Field connections to variables ............................... 46
Database Wizard: Additional Objects ............................................... 47
Database Wizard: Completing the Process ........................................ 49
Using Filters ......................................................................................... 50
Working with Variables ....................................................................... 50
Editing Variables .................................................................................. 50
Internal Variables ............................................................................... 50
Types of Variables ............................................................................... 51
Changing the Size of Multiple Objects Simultaneously .................. 52
Import Variables from the Label ......................................................... 52
Link Object with Variables ............................................................... 52
Print a Label Which File Name is Read from the Database ............... 53
Print Two or More Different Labels .................................................. 54
Quickly Design and Test the Form ...................................................... 54
Change the Focus of the Objects ........................................................ 55
Change the Screen Position of the Running Form ............................ 56
Set the Tab Order in Which the Data is Entered ............................... 56
Use Data from Database ................................................................. 56
Use Distributed Printing ................................................................. 57
Design Form for Mobile Devices ....................................................... 57
Automating the Software .................................................................... 59
Command Line Parameters .............................................................. 59
Technical Support .............................................................................. 61
Online Support .................................................................................... 61
Contact Information ............................................................................ 61
Introduction

About this manual

Your User Manual is composed of four main sections:

**Introduction:** This chapter will introduce you to the software.

**Setting Up the Application:** Learn how to set up and customize software to your preferences.

**Designing Forms:** Learn how to create forms. You should refer to this chapter regularly while designing forms, until you have completely familiarized yourself with the commands. By using the information contained in this chapter, you will be very quickly able to use the software efficiently.

Conventions used in this Manual

Text that appears in **bold** letters refers to the names of the menus, buttons and other 'clickable' things like OK button.

Text that appears in italic refers to the options and confirming actions - like *Read only*.

Text enclosed in brackets refers to keys from the PC keyboard like `<Enter>`.

Variables are enclosed in square brackets like `[variable]`.

Welcome to NiceForm

NiceForm is a software package that helps you create forms for entering data and printing labels. Using NiceForm you can easily design any form with none programming skills required. NiceForm runs under 32-bit and 64-bit Microsoft Windows operating system.

The basic idea of the NiceForm is to simplify entering variable data on the labels. First you have to design the label in NiceLabel using the variables of prompted or database type for the variable fields on the label. Then you can use the NiceForm to create the simple user interface to fill in the variable data needed to print a label. This way the user cannot accidentally modify the label, and entering the data is greatly simplified. The process of printing labels is still performed by NiceLabel (using DDE), although the user sees only the form.
The way of designing forms is very user friendly and flexible. Forms can include different fixed (text, pictures) or variable objects (edit fields, memo fields) and action buttons, which are used to start some sort of action (e.g. print, or change the form).

The forms have two modes: the design mode and the run mode. In design mode you can create and design forms and in the run mode you can enter data and print labels.

NiceForm has the logic that supports default values. This logic speeds up the work and prevents printing labels with incorrect contents.

The DDE (Dynamic Data Exchange) function sends the entered data to the basic program NiceLabel that manages the entire printing process.
Setting up the Application

User Interface

Basic and Advanced User Interface

The software has two-level user interface. By default, basic user interface is enabled that makes the software easier to use for beginners and inexperienced users.

To switch to the Advanced mode showing all program functionality, click on the Advanced button in the bottom of some dialog boxes.

For example:
The dialog box Actions Editor has two-level user interface.

Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete</td>
<td>Deletes selected object</td>
</tr>
<tr>
<td>Shift + Delete</td>
<td>Cut</td>
</tr>
<tr>
<td>Ctrl + Insert</td>
<td>Copy</td>
</tr>
<tr>
<td>Shift + Insert</td>
<td>Paste</td>
</tr>
<tr>
<td>Alt + Backspace</td>
<td>Undo</td>
</tr>
<tr>
<td>Alt + Shift + Backspace</td>
<td>Redo</td>
</tr>
<tr>
<td>Ctrl + A</td>
<td>Align</td>
</tr>
<tr>
<td>Ctrl + X</td>
<td>Cut</td>
</tr>
<tr>
<td>Ctrl + C</td>
<td>Copy</td>
</tr>
<tr>
<td>Ctrl + V</td>
<td>Paste</td>
</tr>
<tr>
<td>Ctrl + Z</td>
<td>Undo</td>
</tr>
<tr>
<td>Ctrl + N</td>
<td>New</td>
</tr>
<tr>
<td>Ctrl + O</td>
<td>Open</td>
</tr>
<tr>
<td>Ctrl + S</td>
<td>Save</td>
</tr>
</tbody>
</table>
**Setting up the Application**

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + F9</td>
<td>Run form</td>
</tr>
<tr>
<td>Ctrl + G</td>
<td>Snap to grid</td>
</tr>
<tr>
<td>Ctrl + Tab</td>
<td>Leave the database table (change focus)</td>
</tr>
<tr>
<td>Alt + F4</td>
<td>Exit</td>
</tr>
<tr>
<td>Ctrl + move object with mouse</td>
<td>Parallel moving of the object by main axes only</td>
</tr>
<tr>
<td>Ctrl + cursor keys</td>
<td>Fine tuning the position of the object, move it in very small steps</td>
</tr>
<tr>
<td>Shift + cursor keys</td>
<td>Fine tuning the dimensions of the object, resize width and height in very small steps</td>
</tr>
<tr>
<td>Turning mouse wheel</td>
<td>Scrolls the form up and down</td>
</tr>
<tr>
<td>Shift + turning mouse wheel</td>
<td>Scrolls the form left and right</td>
</tr>
<tr>
<td>Enter (or F2) with any label element</td>
<td>Open dialog box with element's properties</td>
</tr>
</tbody>
</table>

**Status bar**

Status bar shows information and messages at the bottom of the window that helps you use the application.

Status bar information:

<table>
<thead>
<tr>
<th>Description</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modified</td>
<td>Indicates whether the form has been modified since the last time the file was saved (blank if the file has not been modified).</td>
</tr>
<tr>
<td>Current position</td>
<td>Current position of the mouse cursor. The start of the coordinate system is the upper left corner of the form.</td>
</tr>
<tr>
<td>Label filename</td>
<td>Label file attached to the form (blank if the label file is not attached).</td>
</tr>
</tbody>
</table>
Toolbars

There are several toolbars available in the application. You can hide/show them by choosing the corresponding command in the View menu.

They are fully movable and can be placed anywhere on the screen. They can be docked within the main window or floating outside the main window.

Form Security

Locking Form

In majority of cases you do not want the end-user to be able to modify forms. Once the form is locked, all the actions (button actions, On Load, On Close, On Timer) will be encrypted.

One method to prevent the users having access to the design mode is running the form by double-clicking on its shortcut. This will start the form directly in the Run mode, where no changes can be done. But the user can bypass it by manually opening the form file.

To lock the form, do the following:

1. Open your form.
2. Select the command **Form Properties** in the File menu.
3. Go to the **Advanced** tab.
4. Tick the option **Form locked**.
5. Tick the option **Password protection** and click on the **Set password** button.
6. Provide the password and click on the **OK** button.
7. Click on the **OK** button.
8. Select the command **Save** in the File menu.
9. Close the form.
Designing Forms

Using Toolbars

Using Database Toolbar

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Identity" /></td>
<td>List box lists the links to the databases that are available in the label.</td>
</tr>
<tr>
<td><img src="image" alt="Database wizard" /></td>
<td>Define a link to new database using Database wizard. The Database wizard will guide you through the necessary steps to link database on the label. The result will be database fields available as variables.</td>
</tr>
<tr>
<td><img src="image" alt="Database properties" /></td>
<td>Define new link to the database manually.</td>
</tr>
<tr>
<td><img src="image" alt="Database properties" /></td>
<td>Edit the properties of the selected link to the database. You can change the database driver, select which records will be printed and define if quantity of the labels comes from the database.</td>
</tr>
<tr>
<td><img src="image" alt="Delete" /></td>
<td>Delete the selected link to the database. Note: Make sure that database fields are not used anywhere on the label, linked to objects or used in the functions. Otherwise the link cannot be removed. If you are not sure, where the database fields are used, use the Label Inspector to find that out.</td>
</tr>
<tr>
<td><img src="image" alt="Open database" /></td>
<td>Click on this button to open the database table in database management application.</td>
</tr>
</tbody>
</table>

Using Standard Toolbar

Click on the icons in the standard toolbar will execute the following actions:
Create new form.

Create new form using the wizard.

Open existing form.

Save currently opened label.

Cut the selected objects to clipboard.

Copy the selected objects to clipboard.

Paste the objects from the clipboard.

Undo last action.

Redo last action.

Run the current form. New window with running form will open.

Access to variables. Click on the small arrow for more commands.

Access to the databases. Click on the small arrow for more commands.

Using Text Toolbar

You can use text toolbar to quickly format the text objects on the label.

Here is how:

1. First select it the text object by clicking it.
2. Click the appropriate shortcut button in the text toolbar.
3. To change the font, select the appropriate font from the list in the list box.
4. To change the size of the text, click on the list with font sizes and select appropriate size.

Note:
You can change the fonts size also directly on the label by resizing the text element with a mouse.
5. To format the text bold, italic or underline, click on the appropriate formatting buttons.

| ![Bold](image) | Formats the selected text in bold style. |
| ![Italic](image) | Formats the selected text in italic style. |
| ![Underline](image) | Formats the selected text in underline style. |

**Using Toolbox**

To use the toolbox, do the following:

1. Click on the icon in the toolbox to select the object.
2. Move the mouse over the form. See how the cursors has changed.
3. Click on the form where you want to place the selected object.

Some objects have additional shortcut on the right side of the icon. Using this shortcut you can quickly create a new object with fixed content, create a new variable and connect it to the selected object or connect the object to one already defined variable.

**Using Transformations Toolbar**

Use the transformations toolbar to modify the color, position or arrangement of the objects.

| ![Color](image) | Choose the color for the selected object on the form. |
| ![Align](image) | Align the objects to each other or to the form. Click on the small arrow button for more options. |
| ![Position](image) | Position selected object on the top of all other objects. |
| ![Position](image) | Position selected object on the bottom of all other objects. |

**Note:**

The objects are always aligned to the first selected object.

**Note:**

If you dock the toolbar on the left or the right side of the window, all alignment icons become available.
### Align to horizontal center.

### Align to right.

### Align to top.

### Align to vertical center.

### Align to bottom.

### Distribute selected objects horizontally.

### Distribute selected objects vertically.

**Note:**
If you hold `<CTRL>` key while clicking on the align buttons, the objects are aligned relative to the form instead to each other.

### Using Variable Toolbar

The list box contains the variables available on the form. If you have selected some variable object, the list box displays variable linked to that object. If no object is selected, selecting a variable then clicking on the form places new text object and links it to the variable.

#### Create new variable manually.

#### Edit the properties of the selected variable.

**Note:**
If you select the variable object, the variable linked to the object will be automatically listed in the list.

#### Delete the selected variable.

**Note:**
If you want to delete the variable, you must not use it on the form linked to label objects.

#### Open the variable dialog box.

#### Obtain variables from the label file.
There are several methods to connect a variable to some form objects that should contain variable values.

- If you have the object already positioned on the form, select it, then choose the appropriate variable in the list.
- If the object is not already on the form, you can first select the variable in the list and then click the form where you want the element positioned. Text element will appear there and will be connected to the chosen variable.
- If you want any other object (and not text) connected to the variable, you can first select the variable in the list, then click the desired element in the Toolbox and then click on the form.
- You can click on the small arrow button next to the object icon in the toolbox, select the option **Use Existing Variable**, select the variable from the list and click on the form.

Variable toolbar always shows the name of the variable, which is attached to the currently selected object. If there are two or more elements selected and do not have the same variable attached to it, then the variable combo box is empty.

---

**Working with Objects**

**Working with Buttons**

**Defining Actions**

**Browse for File or Folder**

The action opens a file browser window. The action settings offer details which enable easier contextual file or folder browsing, such as a pre-defined extension filter and starting directory.

**Note:**

If the checkbox is marked to indicate that the name of the selected file will be saved as a variable, see the appropriate sections of Help to learn more about variables.

**Filter:** Define the file browsing filters. You may choose between preset filter choices or enter your own.

**Initial Directory:** Choose which folder will be open by default in the browsing window.
**Condition**: This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

**Close Label**

Use this command to force closing the label that you previously opened with a command **Open Label**.

Do not use this action if printing speed is important to you. By default, NiceForm will open the label and keep it open as long the application runs. Keeping the label open saves you time you would otherwise spend for re-loading the label. In time-critical label-printing environments every second can count.

**Note**: NiceForm will not see the changes in the label file that label designer made and will continue to print the older label contents. If the design of your label templates changes frequently, make sure to use the action Close Label, otherwise don't use it to speed up printing.

**Define Printer Settings**

The action displays the dialog box with properties of the form's selected printer.

This way the end user can change the printer properties like printing speed, darkness, and other controls independently from the current printer settings in the label, in the printer driver or printer hardware settings. The modifications the user makes are temporarily and influence current print job only. The modifications are not saved in the label or form.

**Condition**: This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

**Execute Script**

This action defines the programming script that you can use for advanced data manipulation on the form. The scripting allows you to implement some feature that is not built-in the application and expand the possibilities in your forms.

Several scripting languages are supported on the form, but only one at a time. To choose between scripting languages see the options in *File -> Form Properties -> Scripting*.

**Define Script**: Type in your script in the text area.

**Build Script**: Click on this button to open the Expression Editor that will help you construct your script. The button might not be available for all scripting languages.
Check Script: Click on this button to verify the syntax of your script. If there is a syntax error in your script, you will be notified about it.

Condition: This is a scripting boolean expression. Only two results are possible (True and False). Use this option to execute the current action Execute script only when the condition is True.

Execute SQL Statement

Here you can define a custom SQL statement that can add, modify, or delete data in the database table.

When running forms on desktop platform you can use the SQL commands SELECT, INSERT, UPDATE and DELETE. When running forms on the web platform you can use all SQL commands.

This procedure is considered advanced and requires prior SQL programming knowledge.

SQL Statement: Type in the SQL commands to execute with this action. To use form's variables in the SQL statement, put a colon (:) in front of their name. If the form variable includes a space, enclose the variable in square brackets [].

For example: The user works with his customer database. The table Customers includes a field named Customer_ID. There is a variable ID defined in a form. The user enters the value for ID using an edit field and wants to delete all customer information for the entered ID. The SQL statement will delete all records where the value of the Customer_ID field is equal to the entered ID number (Customer_ID = ID).

You must use the variable ID in your SQL statement. In NiceLabel software you can do it by including colon character (:) in front of the variable name, like this:

```sql
DELETE FROM Customers WHERE Customer_ID = :[ID]
```

To test your SQL statement, click the Execute button.

The result of your SQL statement is remembered in the variable you select in the Variable section.

- When you use commands INSERT, UPDATE or DELETE the variable will contain the numerical value, which represents the number of the rows affected by the command. You can use this result for execution tracking. If the result is 0, no updates were done in the database.
- When you use command SELECT the variable will contain the result returned from the database server.

The result for SELECT command can be:
• **Value of a single field**: in this case your SQL statement is written to return just single field from one record field.
  
  Sample statement:
  
  ```
  SELECT MyField FROM dbTable WHERE ID = 1
  ```
  
  Result: If there is just one record matching the above condition, the value of variable will be value of field *MyField*.

• **Values of two or more fields, in one or more records**: In this case a dataset is returned. Each line in the dataset contains data from one record, fields are included in the line, delimited by comma (,). The first line will contain names of the fields. You will have to write a script to parse the values into individual values, if you want to use individual fields in the form.
  
  Sample statement:
  
  ```
  SELECT * FROM dbTable WHERE ID = 1 OR ID = 2
  ```
  
  The result:
  
  "ID","MyField"
  
  "1","field1"
  
  "2","field2"

  **Condition**: This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

**For Every Label**

The property defines the list of labels for which all defined actions will be executed.

**Fixed values**: Define the list of labels.

• **Add**: Add labels to the list.

• **Arrow next to the Add button**: Add variables to the list. The variables must contain the path and name of the label.

• **Delete**: Remove the selected item from the list.

• **Arrow buttons**: Change the order of labels in the list. This is the order in which the labels are printed.

**Variable value**: Select one variable that will contain the path and name of the label.

**Condition**: This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.
For Every Record in a Table

The property defines the table. All records or all selected records from the table will be used in the defined actions.

**Table:** Select the name of the table you want to use.

**Use selected records only:** Enable this option to use only selected records in the defined actions, not all records in the table.

**Note:** The database table must already be defined on the form.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

For Loop

For loop makes it possible for the action to be executed a certain number of times.

**Loop from:** Select a starting value for the incremented loop.

**Loop to:** Select an end value for the incremented loop.

**Note:** If the loop from value is higher than the loop to value, the loop will decrement the value regressively.

The **Loop from** and **Loop to** values can be fixed or variable, and the current loop value can also be saved into a variable.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

Import Data Into Database

Here you can define the action that will take data from the text data file and import it into the SQL database.

Before you can use this action, you must already create a connection to the SQL database. The action does not work with file-based databases, like Microsoft Access, or data files like Microsoft Excel, or plain text files. You must use server-based SQL database, like Microsoft SQL.

**Note:** The action is only available for forms running on the Web platform, not for forms running on a desktop platform.

Rules:
- The first line in a text file must define field names
- The field names in the text file must match field names in the database table
- If the text file does not provide a value for some field, NULL will be written to the database. If the field does not accept NULL values, then the empty string "" will be written.
- Setting values for auto-incremental fields is ignored. The database will provide value for such field, value for such field from the text file is ignored, but the rest of the fields in a record will be written to the table.
- If the value from text file does not match the structure of the field, the action is canceled and error message displayed. E.g. you want to write alphanumerical value into numerical field.
- If you filter records in the form and display just records matching some condition, you can only import records that either do not provide value for the filter field, or provide the same value for the filter as your form has defined. You can only use filters with "equal" condition, not "greater than", "less than", "contains" or similar.
- If the text file contains fields not defined in the SQL database, the import will ignore them. Only known fields will be imported.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

**Load Variable Data**

This action reads the data from the text file and sets values to the variables on the form.

**File Name:** Specify the name of the text file with data. It can be fixed or variable.

**Advanced Options:** Click on this button to select variables you want to load from the text file and define the structure of the text file.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

**Move Focus to Object**

This action moves the focus to a particular object on the label. When some object has the focus, it is active and you can use it without selecting it with the mouse first. Normally, the focus is moved from one object to another with press of a tabulator (Tab) key on the keyboard. The tab order is defined during the form design process.
If you do not change the tab order, the default tab order is the order in which you put the objects on the form.

**Note:** To see the tab order, select Design -> Tab Order.

However, you can also use this action to put the focus on some form object. Whenever the action executes, the selected object will have the focus.

**Move focus to first object in tab order:** When the action executes, the first object in the tab order will have the focus.

**Move focus to the selected object:** When the action executes, the selected object will have the focus.

**Note:** You can define the object names that you see in the combo box. Each object has an unique name in the Advanced tab of its properties.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

Open Another Form

This action will close the current form and open the specified form.

**File Name:** Select a fixed form name on the hard disk or select a variable containing the name of the form.

**Previously opened form:** The form that was used to open the current form will be re-opened. The history of opened forms is remembered, and you can go back several levels deep.

**Note:** The result of using the **Previously opened form** option is the same as if you would click Back button in your Internet Explorer while browsing the internet.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression (this setting is only available in the advanced Action Editor mode).

Open Document/Program

The action executes the specified program or opens the specified document, when the button is clicked.

**File Name:** Define a file name for the document/program that you want to open. Include full path to the program or document.
**Note:** If you are opening a program, you can also include variables as parameters in the command line. Enclose the variables in the square brackets. For example: c:\program files\my_program.exe [Variable]

**Hide window:** Enable this option to hide the Command Prompt window that displays when the selected application launches. Usually you do not want the user to see the black Command Prompt window.

**Wait for completion:** Enable this option if you want to wait for the result from the application that you run and the next actions in the list rely on its completion.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

**Open Label**

This action defines the label file that will be used to printing, when the user clicks on the button.

**Label:** Define the fixed name of the label or select the variable containing the path and name to the label.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression (this setting is only available in the advanced Action Editor mode).

**Note:** The action Open Label can contain other actions nested below it. You must always use the Open Label action to print labels and executing some other actions. Such actions cannot exist on their own, but are always nested below Open Label action.

**Print Label**

This action executes the printing command and defines how many labels will be printed.

**Number of Labels:** Define how many labels should be printed.

- **Fixed:** The number entered in the edit field defines how many labels will be printed.
- **Unlimited:** The maximum quantity of labels supported by the current printer will be printed. This options is generally used with database files, where unlimited would be used as: print the whole database.

**Note:**
Be careful and do not create an infinite loop, when label printing would not end.
• **Variable quantity:** Some variable on the label will set the quantity of labels to be printed. In most cases this will be some field from the database. The form does not know how many labels will be printed. When the data is processed on the label, the variable quantity gets its value.

• **From variable:** The value of the selected variable defines the quantity of labels that will be printed.

**Advanced Options:** Click this button to set advanced options for the quantity of labels.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression (this setting is only available in the advanced Action Editor mode).

**Read Data from Serial Port**

Define how the data will be read from the serial port.

The data received on the serial port is stored in the generated variable. You can use the value of the variable directly on the label or use it in some other action in the form (like Visual Basic script if additional data-manipulation is required).

**Serial Port Settings:** Define the properties of the serial port where you have attached the serial device. The parameters in this dialog box have to match the settings on the device. Refer to the documentation of your serial communication device so you will be able to specify the correct communication parameters. If the settings on the device and in the software do not match, communication will not be possible.

**Initialization Data:** Initialization data is set of characters that need to be sent to the serial device in order to activate it and make it ready to send data to the PC computer. Type in the set of characters that must be sent to the device. Click on the small arrow button on the right to display list of all available special characters.

  **Send initialization data:** Tick the option to enable initialization data. This is optional feature.

  **Wait before starting to read data:** You can define the time-out in milliseconds after which the receiving data will begin. This is optional feature.

**Filter:** You can filter the data you receive from the serial port and cut only the important characters. You can limit what data you will receive. This is optional feature.

  **Use start and stop string:** Define the two strings that will enclose the data you need to extract. For example, if start string is ### and stop string is $$$, the extracted data from the raw data q###12345$$1 is 12345.
Use start and end position: Define the start and stop position of characters you want to extract. For example, if start position is 10 and stop position is 14, the extracted data from the raw data q###12345$$$1 is 12345.

Condition: This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

Refresh Database

The action refreshes a database object on the form. There must be a database object on the form for this action to be available.

Condition: This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

Refresh Previews

The action refreshes all label preview objects on the form.

By default each label preview updates itself automatically as soon as the data it previews changes. In some cases --especially when a lot of variables and database fields are used on the label-- the label preview might be slowing down the user experience. A solution is to disable automatic refresh of the label preview. When you want to update the previews, use this action.

Condition: This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

Run Command File

Executes the commands in the specified command file. The following types of the command files are supported:

- JOB file
- XML file
- CSV (Comma Separated Values) file

All of the command files provide the commands to instruct the print engine what to do. In most cases you want to open the label, set the values to variables on the label and print the label to the specified printer.

See the chapters in the section Integration and Connectivity in the label designer user guide or Automating the Software in middleware integration module user guide.
**File Name:** You can set a fixed command file name or let some variable define it.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

**Save Variable Data**

This action saves the data from the variables to the text file.

**File Name:** Specify the name of the text file with data. It can be fixed or variable.

**Advanced Options:** Click on this button to select variables you want to save from the text file and define the structure of the text file.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

**Select Variables**

Select the variables which values you want to save/load to/from file. Use Up and Down arrows to set the order of appearance in which values are defined in the text file.

**Send Custom Commands**

Send the defined list of commands to the print engine for execution.

**Commands:** Enter the commands in the text area.

**Edit:** Click on the Edit button to open the Expression Editor that will help you define the script of custom commands.

You can also include variables in the commands. Just type in the variable name and enclose it with the square brackets.

**For example:**
To print the number of labels as specified in the variable Quantity, the print command should look like PRINT [Quantity]

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

**Note:**
For more information about commands refer to the help or user guide.
Send Data to TCP/IP

Define the sending of data to the TCP/IP port.

**Destination:** Define the destination to which you wish to send the TCP/IP data. If you only provide the address and not the port number, the port will default to 80. Click on the detailed settings button to enter the host name or port number separately, or to connect them with a variable.

**Content:** Set the data to be sent to the TCP/IP port.

**Encoding:** Set the encoding data.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

Set Printer

The action defines the printer name that you want to use for label printing. This setting will override the printer setting that were set directly on the label.

**Note:**
This action is useful, if you want to print one label file to several different printers without the need for creating duplicated label files linked to different printers.

**Printers:** Define fixed name of the printer or select the variable name containing the name of the printer.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression (this setting is only available in the advanced Action Editor mode).

Set Variable

The actions sets the defined value to the selected variable.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.
View Log File

This action opens the printing log file for the current workstation. As such, the button with this action offers access to the reprinting function, where past print jobs can be selected in the log file and reprinted.

**Reprinting:**

1. Define how many labels should be printed
2. Select the printer for the reprinting
3. Select the individual labels for reprinting in the list.

**Note:** If many labels are listed, you can use the search function to locate the label that you wish to reprint.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

Verify License

This action allows the user to insert a license check to the trigger.

- If the entered **Solution ID** number is not the same as the ID of the application, no actions will be executed.
- If the entered value is 0, actions will be executed if any valid license is found.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

Write Data to Serial Port

Define how the data will be written to the serial port.

The data sent to the serial port is stored as a fixed value or in the generated variable. You can use the value of the variable directly on the label or use it in some other action in the form (like Visual Basic script if additional data-manipulation is required).

**Serial Port Settings:** Define the properties of the serial port where you have attached the serial device. The parameters in this dialog box have to match the settings on the device. Refer to the documentation of your serial communication device so you will be able to specify the correct communication parameters. If the settings on the device and in the software do not match, communication will not be possible.
**Data:** Set the data to be sent to the serial port as fixed data or data from a variable. Type in the set of characters that must be sent to the device. Click on the small arrow button on the right to display list of all available special characters.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

**Quit**

The action will close the currently running form.

If you are a form designer, executing Quit action will close the running form and return you back to the form designer.

When the print operator (the end user) will execute Quit command, the form will close entirely.

**Condition:** This is a scripting boolean expression. Only two results are possible (True and False). Use this option to enable current action only when some term is met. The action will be started only if condition returns True as the result of the expression.

**Creating the Button**

To use the button object, do the following:

1. Click on the icon in the toolbox.

**Note:**
You can also select the command Button in the Object menu.

2. Click on the form, where you want to position the object.
   The dialog box opens with object properties.
3. Go to the Actions tab.
4. Click on the Edit button to open the Actions Editor window.
5. Define the actions you want to execute when the user will click on the button.
   Drag the appropriate actions from the list on the left side to the right working area.
   Set the action properties, if necessary.
6. When ready, click on the OK button to close the Actions Editor.
7. Click on the OK button.

**Note:**
To cancel placing an object on the form, press the ESC button.
Working with Button Group

Creating the Button Group

To use the button group object, do the following:

1. Click on the Button Group icon in the toolbox or select the command Button Group object in the Object menu.
2. Click on the form, where you want to position the object. The dialog box opens with object properties.
3. Go to the Actions tab.
4. Click on the Edit button to open the Actions Editor window.
5. Define the actions you want to execute when the user will click on buttons. Drag the appropriate actions from the list on the left side to the right working area. Set the action properties, if necessary.
6. When ready, click on the OK button to close the Actions Editor.
7. Click on the OK button.

Note: To cancel placing an object on the form, press the ESC button.

Working with Check Boxes

Creating the Check Box

To use the check box object, do the following:

1. Click on the icon in the toolbox.

Note:
You can also select the command Check box in the Object menu.

2. Click on the form, where you want to position the object.
3. Double click on the object.
   The dialog box opens with object properties.
4. Go to the Contents tab.
5. Select the variable from the list that will store the value for check box state (enabled/disabled).
6. Go to the Values tab.
7. Type in the text for the check box. The text will explain to the user what he can enable/disable with the check box.
8. Enter the values for both states of the check box (enabled and disabled).

Note:
If no variable is available in the list, import the variables from the label (Design -> Get Variables) or click on the button New.
10. Click on the **OK** button.

**Note:**
To cancel placing an object on the form, press the ESC button.

**Working with Combo Boxes**

**Working with Combo Box**

To use the combo box object, do the following:

1. Click on the ![Combo Box](icon.png) icon in the toolbox.

**Note:**
You can also select the command Combo box in the Object menu.

2. Click on the form, where you want to position the object.
3. Double click on the object.
   The dialog box opens with object properties.
4. Go to the **Contents** tab.
5. Select **Variable value** for the contents.
6. Select the variable from the list. This variable will store the value the user will select.

**Note:**
If no variable is available in the list, import the variables from the label *(Design -> Get Variables)* or click on the button **New**.

7. Go to **Values** tab.
8. Click on the **Edit** button.
   The **Edit items** dialog box opens.
9. Enter the values that will be available for the selection. Each line contains one value.
10. Click on the **OK** button to close **Edit items** dialog box.
11. You can use the Up and Down arrows to change the order of appearance of your pre-defined values.

**Note:** You can also use keyboard shortcuts Alt + Up and Alt + Down to change the position of values in the list.

12. Click on the **OK** button.

**Note:**
To cancel placing an object on the form, press the ESC button.
Working with Database Navigator

Creating the Database Navigator

To use the database navigator object, do the following:

1. Click on the icon in the toolbox.

   **Note:**
   You can also select the command Database Navigator in the Object menu.

   2. Click on the form, where you want to position the object.
   3. Double click on the object.
      The dialog box opens with object properties.
   4. Go to the **Database** tab.
   5. Select the database from the list.

   **Note:**
   If no database is available in the list, click on the **Edit** button and create a link to the database.

   6. Click on the **OK** button.

Working with the Database Navigator

The database navigator is used to move the focus from one record in the database to the next.

All objects that are connected with the fields from the same database that database navigator is linked to will change, when you use the database navigator.

**Note:**
The database navigator is also part of the table object. You would use it as a separate object, if you do not use the table object on the form.

The available buttons in the database navigator are:

<table>
<thead>
<tr>
<th></th>
<th>First record</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Prior record</td>
</tr>
<tr>
<td></td>
<td>Next record</td>
</tr>
<tr>
<td></td>
<td>Last record</td>
</tr>
</tbody>
</table>
### Working with Database Search

#### Creating the Database Search

To use the database search object, do the following:

1. Click on the ![Database Search](image) icon in the toolbox.

   **Note:**
   You can also select the command Database Search in the Object menu.

2. Click on the form, where you want to position the object.
3. Double click on the object.
   
   The dialog box opens with object properties.
4. Go to the **Database** tab.
5. Select the database from the list.

   **Note:**
   If no database is available in the list, click on the **Edit** button and create a link to the database.

6. Click on the **OK** button.

   **Note:**
   To cancel placing an object on the form, press the ESC button.

Searching for an entry in the database will also select the corresponding database record in Edit fields with an enabled lookup setting, if they are connected to the same database.

#### Working with the Database Search

The database search is used to search for the records in the database. Only records complying with the condition are obtained from the database.

**Note:**
The database search is also part of the table object. You would use it as a separate object, if you do not use the table object on the form.

The available buttons in the database search are:

| Mary | Edit box for entering the data database search must find in the database. |
Click on this button to perform the search.

Select the field from the database, where the search will be conducted.

Enable filter functionality. You can add advanced filters to the database.

**Working with Edit Fields**

**Creating the Edit Field**

To use the edit field object, do the following:

1. Click on the icon in the toolbox.

**Note:**
You can also select the command Edit field in the Object menu.

2. Click on the form, where you want to position the object.
3. Double click on the object.
   The dialog box opens with object properties.
4. Go to the **Contents** tab.
5. Select **Variable value** for the contents.
6. Select the variable from the list. This variable will store the value the user will provide.

**Note:**
If no variable is available in the list, import the variables from the label *(Design -> Get Variables)* or click on the button **New**.

7. Click on the **OK** button.

**Note:**
To cancel placing an object on the form, press the ESC button.

**Working with Frame Objects**

**Creating the Frame Object**

To use the frame object, do the following:

1. Click on the icon in the toolbox.
Note:
You can also select the command Frame in the Object menu.

2. Click on the form, where you want to position the object.
3. If you click once, the frame is inserted in a default size. You can click once and hold the left mouse button, then drag in the desired direction to resize the frame.

Note:
To change the object properties, double click on it. To cancel placing an object on the form, press the ESC button.

Working with List Boxes

Creating the List Box

To use the list box object, do the following:

1. Click on the List Box icon in the toolbox.

Note:
You can also select the command List box in the Object menu.

2. Click on the form, where you want to position the object.
3. Double click on the object.
   The dialog box opens with object properties.
4. Go to the Contents tab.
5. Select Variable value for the contents.
6. Select the variable from the list. This variable will store the value the user will select.

Note:
If no variable is available in the list, import the variables from the label (Design -> Get Variables) or click on the button New.

7. Go to Values tab.
8. Click on the Edit button.
   The Edit items dialog box opens.
9. Enter the values that will be available for the selection. Each line contains one value.
10. Click on the OK button to close Edit items dialog box.
11. You can use the Up and Down arrows to change the order of appearance of your pre-defined values.

Note: You can also use keyboard shortcuts Alt + Up and Alt + Down to change the position of values in the list.

12. Click on the OK button.
Note:
To cancel placing an object on the form, press the ESC button.

**Working with Memo Fields**

**Creating the Memo Field**

To use the memo field object, do the following:

1. Click on the ![Memo Field](image.png) icon in the toolbox.

- **Note:**
  You can also select the command Memo field in the Object menu.

- 1. Click on the form, where you want to position the object.
- 2. Double click on the object.
  The dialog box opens with object properties.
- 3. Go to the **Contents** tab.
- 4. Select **Variable value** for the contents.
- 5. Select the variable from the list. This variable will store the value the user will provide.

- **Note:**
  If no variable is available in the list, import the variables from the label (Design -> Get Variables) or click on the button ![New](image.png).

- 6. Click on the **OK** button.

- **Note:**
  To cancel placing an object on the form, press the ESC button.

**Working with Pictures**

**Creating the Picture Object**

To use the picture object, do the following:

1. Click on the ![Picture](image.png) icon in the toolbox.

- **Note:**
  You can also select the command Picture in the Object menu.

- 2. Click on the form, where you want to position the object.
  The **Open** dialog box opens.
- 3. Browse for the picture that you want to use.
- 4. Click on the **Open** button.
Note:
To change the object properties, double click on it. To cancel placing an object on the form, press the ESC button.

**Working with Previews**

**Creating the Preview**

To use the preview object, do the following:

1. Click on the \[Preview\] icon in the toolbox.

Note:
You can also select the command Preview in the Object menu.

2. Click on the form, where you want to position the object. The dialog box **Select Label File** opens.
3. Browse to the label file you want to preview on the form.
4. Click on the **Open** button.

Note:
To cancel placing an object on the form, press the ESC button.

**Working with Radio Groups**

**Creating the Radio Group**

To create the radio group object, do the following:

1. Click on the \[Radio group\] icon in the toolbox.

Note:
You can also select the command Radio Group in the Object menu.

2. Click on the form, where you want to position the object.
3. Double click on the object. The dialog box opens with object properties.
4. Go to the **Contents** tab.
5. Select **Variable value** for the contents.
6. Select the variable from the list. This variable will store the value the user will select.

Note:
If no variable is available in the list, import the variables from the label (**Design -> Get Variables**) or click on the button **New**.

7. Go to **Values** tab.
Designing Forms

8. Click on the **Edit** button. The **Edit items** dialog box opens.
9. Enter the values that will be available for the selection. Each line contains one value.
10. Click on the **OK** button to close **Edit items** dialog box.
11. Click on the **OK** button.

**Note:**
To cancel placing an object on the form, press the ESC button.

**Working with Tables**

**Create the Table Element**

To use the table object, do the following:

1. Click on the [Table](#) icon in the toolbox.

**Note:**
You can also select the command Table in the Object menu.

2. Click on the form, where you want to position the object.
3. Double click on the object. The dialog box opens with object properties.
4. Go to the **Database** tab.
5. Select a database from the list.
   If no database is available in the list, click on the **Edit** button and define a link to the database.
6. Go to the **Columns** tab.
7. Link each database field with the appropriate label or form variable.

**Note:**
If no variable is available in the list, import the variables from the label before you can use the table object.

8. Click on the **OK** button.

**Note:**
To cancel placing an object on the form, press the ESC button.

**Formatting Table Object**

To change the format of columns in the table, do the following:

1. Double click on the table object.
   The dialog box opens with object properties.
2. Go to the **Columns** tab.
3. Select the database field you would like to format.
4. Click on the **Display Style** button.
5. Format the title and data area.
   The title are is the caption of the field, the data area displays the records from the database.
6. Click on the **OK** button to close Column Properties dialog box.
7. Click on the **OK**.

**Linking Fields with Variables**

To link database fields with appropriate variables in the table object, do the following:

1. Double click on the **Table** object.
   The properties of the table object will open.
2. Go to Database tab.
3. Make sure the proper database is selected in the list.

**Note:**
If no database is available in the list, click on the Edit button and define the link to the database.

4. Go to the **Columns** tab.
5. Click on the **<not connected>** entry next to the database field and select the proper variable from the list.

**Note:**
If no variable is available in the list, attach a label to the form. During the attaching process the form will import the label variables.

6. Repeat step 5 for all other database fields that need to be linked with the variables.
7. Click on the **OK** button.

**Using Master - Detail Connection**

Master - detail connection is the functionality available in the table element that allows you to link two database tables together. The first table is master table. The second table is slave table that displays only the records that comply with the selected record in the first database. One field in the master table links to the field in the slave table. Only the records in the slave table that have the same contents in that linked field as the master database are displayed.

**The example:**
Here is most likely usage of the Master Detail Connection functionality. There are three database tables that contain information about customers, orders and items that you want
to use on the form. Using Master Detail Connections allows you to construct linked tables which data changes according to the selection in the parent table.

<table>
<thead>
<tr>
<th>CUSTOMERS</th>
<th>The table contains a list of all customers with the IDs of their orders.</th>
</tr>
</thead>
<tbody>
<tr>
<td>ORDER S</td>
<td>The table contains a list of all orders that the customers have made.</td>
</tr>
<tr>
<td></td>
<td>The orders contain the IDs of the items they include.</td>
</tr>
<tr>
<td>ITEMS</td>
<td>The table contains information about the items.</td>
</tr>
</tbody>
</table>

All three tables need to be positioned in the form. The first table form element has to be connected to CUSTOMERS database table (this is done in the Database tab) and Master Detail Connection is disabled on it.

The second table on the form is connected to ORDERS database table (this is done in the Database tab). The table with Customers is the parent table for the Orders table. They will have to be linked together. Connect the ORDER_ID field from the CUSTOMERS database with the ORDER_ID field in the ORDERS database. This link will ensure that only the Orders for the customer selected in the first table will be shown in the second one.

Then connect the third form table element to the ITEMS database table. The Orders table is a parent for the Items table. They too will have to be linked together. This will ensure that only items from the selected Order (from the second database) will be shown in this third database table.

The result of all this preparations is the following. The user selects the customer in the first table (Customers), the second table (Orders) is automatically refreshed and displays only orders that the selected customer has performed. When the user selects the appropriate order from the second table, the third table (Items) is automatically refreshed and displays only the items the selected customer has order in the selected order.

**Working with Text Objects**

**Creating the Text Object**

To use the text object, do the following:

1. Click on the icon in the toolbox.

Note: You can also select the command Text in the Object menu.
2. Click on the form, where you want to position the object. The dialog box opens with object properties.
3. Enter the content for the object, then click on the **OK** button.

**Note:**
To change the object properties, double click on it. To cancel placing an object on the form, press the ESC button.

### Working with Variable Prompts

#### Working with the Variable Prompt

To use the Variable Prompt object, do the following:

1. Click on the ![Variable Prompt](image) icon in the toolbox.

**Note:**
You can also select the command Variable Prompt in the Object menu.

2. Click on the form, where you want to position the object.
3. Double click on the object.
   The dialog box opens with object properties.
4. Go to the **Content** tab.
5. Select **Variable** from the **Content** pane.
6. Review the form variables or add new variables, and edit the length, default values, and entry type limitations of current variables.

Your Variable Prompt object is set up and ready for use in the form.

#### Aligning Objects on the Form

1. Select all objects that you want to align.

**Note:**
Press and hold `<Shift>` key while clicking on the objects to select more than one object.

2. Select the command **Align** from the Transformations menu.
   The same align options are available in the Transformations toolbar.

#### Moving and Resizing Objects

You can move selected objects to another position by dragging them, or resize them, by selecting object's handles and dragging them in the desired direction.
Selecting Objects

To select an object, simply click on it. To select more than one object, hold <Shift> while clicking.

You can also drag a rectangle around the objects to select all of them. The rectangle does not have to enclose all of them, it is enough that it only touches the objects you want to select.

Using the keyboard to select objects

You can also use keyboard shortcuts to select move and resize objects.

<table>
<thead>
<tr>
<th>Cursor keys</th>
<th>Selects new object that is Up (down, left, right) from the one already selected.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + Cursor keys</td>
<td>Moves the currently selected object in the direction of the pressed cursor key.</td>
</tr>
<tr>
<td>Shift + Cursor Keys</td>
<td>Resizes the selected object.</td>
</tr>
</tbody>
</table>

Working with Variable Data

Contents Providers

Contents Provider is an expression for any method that can be used as an source of data for elements on the form. It is applicable to all form elements that can have some sort of data associated with them.

The contents provider for objects can be one of the following:

<table>
<thead>
<tr>
<th>Fixed</th>
<th>When you select Fixed, you can enter a desired value in the edit box. This value will remain the same for the object. To edit the text, all standard Windows editing features (cut, copy, and paste) can be used.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variable</td>
<td>When the Variable option is selected, you can connect any variable field to the element, just select the appropriate variable name from the list. This approach will allow you to change the</td>
</tr>
</tbody>
</table>
variable value on the labels.
If no variable is defined on the label, you should first create one or import them from the labels.

| Database | When this type of contents provider is selected, you can select the database field and link it to the object. The data from the database table will be used for the object. |

**Working with Databases**

**Database Wizard**

Database wizard lets you specify the source database for the table in an easy step by step procedure. Click the Wizard button in the **Database Access Functions** dialog box or click the Wizard button in the Database Tool.

The Database Wizard offers you a quick and easy method to make database table available to the form elements. When the Wizard is finished, it will leave you with ready-made connection. You can further modify the table layout and properties or use it as-is. This is a great shortcut for designing quick connectivity to data in database tables.
Database Wizard: Starting

On the starting screen of Database Wizard you will learn what tasks will be completed. Wizard will comfortable guide you through each required step. The result of the Wizard will be database table connected on the form. The database fields will be linked to form objects.
Database Wizard: Selecting the Database File

First you must select the database file, which has stored the appropriate data, you would like use. Wizard can work with MS Access, dBase, Paradox, and MS Excel databases. If you have any other type of database, you will have to make a manual connection to the database and you cannot use the Wizard.

Select the database file and click on the Next button to continue with the Wizard.
Database Wizard: Field Usage

Select how the database fields should be used on the form.

I want a table: A table object is used on the form and linked to the database.

I want an edit field for each field in the database: Edit field objects are linked with each database fields.
I will link the database fields to the objects myself later: The wizard will only make the link to the database, but will not make the fields available on the form. You will have to link them to objects yourself.

Database Wizard: Select Fields

Select the database fields you want to use on the form. Use the arrow buttons for managing the fields.

Available table fields: All fields defined in the database.
**Selected fields:** The fields to be used on the form.

Click the arrow buttons to select fields.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Move selected field to the right side and use it on the table.</td>
</tr>
<tr>
<td></td>
<td>Move all fields to the right side and use them on the table.</td>
</tr>
<tr>
<td></td>
<td>Move all fields back to the left side and do not use them on the table.</td>
</tr>
<tr>
<td></td>
<td>Move selected field back to the left side and do not use it on the table.</td>
</tr>
</tbody>
</table>

Fields on the right side can be ordered. The first in the list will be the leftmost in the table element, the last in the list will be the rightmost in the table. Use up and down arrow buttons to change the order of fields.
Database Wizard: Field connections to variables

You have to make a connections between database fields and variables on the form. The purpose of this connection is to let the application know to which variable it has to assign a value read from the database table. If you are using the same variable's names as the names of the fields, the application will make the connections automatically. Variables and fields with the same names will be connected together. If the names are not the same, you will have to make connections yourself.

To add the link, do the following:
1. Select the field name from the left pane and appropriate variable name from the right pane.
2. Click on the Add button to make a connection.

Delete: Deletes the currently selected connection from the bottom list.

Clear: Clear all defined connections.

Click on the Next button to continue with the Wizard.

Database Wizard: Additional Objects

If you have specified that the Wizard should create a table element connected to the database, this table will also contain a search control and database navigator. But if you have selected that you need an edit field for each database field, you have the option to select additional objects that can be positioned on the form as well.

<table>
<thead>
<tr>
<th>Search Control</th>
<th>For more information refer to the topic Database Search.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database Navigator</td>
<td>For more information refer to the topic Database Navigator.</td>
</tr>
</tbody>
</table>
Database Wizard: Completing the Process

All information required by the Wizard have been entered. You can review the changes you have made. If you are not satisfied with the settings, click Back to return to previous step of the Wizard. Click Finish to close the Wizard and create a new table connectivity based on parameters you entered.
Using Filters

If you add the filter in the DESIGN mode on the form, such filter is stored with the form and is applied every time the form is run. The user cannot remove such filter. If the user adds some custom filter in RUN mode, such filter is not stored with the form. It is active only for as long as the form is running. When the form is closed, the filter is discarded and is not applied at next form run.

Working with Variables

Editing Variables

You can only edit internal variables on the form.

If variable is defined and acquired from label file, you cannot make any modifications. When you want to change such variable, you will have to make modifications to the variable on the label. When you will re-open the form file, the application will automatically update the variable settings.

Internal Variables

Internal variables are filled automatically by the software and you do not have any influence on them. They cannot be edited and modified, but only used on the form. Their value is updated for every printed label.

Internal variables are represented with the 📋 icon so they can be easily distinguished from the other types of variables.

The list of available internal variables:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ComputerName</td>
<td>Contains the information about the computer name of a PC computer where labels are processed, as specified from Windows system.</td>
</tr>
<tr>
<td>Date</td>
<td>Contains the current system date.</td>
</tr>
<tr>
<td>DefaultPrinterName</td>
<td>Contains the name of the default printer on the system.</td>
</tr>
<tr>
<td>FormName</td>
<td>Contains the name of the form file that is currently used.</td>
</tr>
<tr>
<td>LabelName</td>
<td>Contains full name of the current label, including the path to the file.</td>
</tr>
<tr>
<td>LabelPrinterName</td>
<td>Contains the name of the printer that is used on the label.</td>
</tr>
<tr>
<td>Variable</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ShortFormName</td>
<td>Contains the name of the form file without the path. Only filename with the extension OFF is available.</td>
</tr>
<tr>
<td>ShortLabelName</td>
<td>Contains the name of the label without the path. Only filename with the extension LBL is available.</td>
</tr>
<tr>
<td>SystemUserName</td>
<td>Contains the name of the system Windows user that is logged in and is running the application.</td>
</tr>
<tr>
<td>Time</td>
<td>Contains the current system time.</td>
</tr>
<tr>
<td>UserName</td>
<td>Contains the name of the Label Gallery user that is logged in and is using the application. This variable has some value only when you have enabled user management in the software.</td>
</tr>
</tbody>
</table>

**Types of Variables**

Each type of variable has its own icon to easier distinguish variables among each other. The icon in front of the variable name determines its type.

The available types of variables are:

- **Prompt variables** that are defined in a label file. The application reads these variables from the label file and show them in the list.

- **Database variables** that are defined in a label file. The application will read these variables from the label file and show them in the list.

- **Local variables** on the form. These variables are local to the form and are not included in the label file. You can use these variables on the form and in the actions.

- **Internal variables** on the form. These variables are local to the form and are not included in the label file. You can use these variables on the form and in the actions. Internal variables cannot be modified, you can only use them.
Changing the Size of Multiple Objects Simultaneously

1. Select all objects that you want to resize.

**Note:**
Press and hold <Shift> key while clicking on the objects to select more than one object.

2. Select the command **Size** from Transformations menu.

---

Import Variables from the Label

1. Select the command **Get Variables** from the Design menu. The Select Label File dialog box opens.
2. Select the label files from which you want to import the variables.
3. The prompted variables that exist in a label file are available on the form. These variables can now be connected with specific objects on the form.

**Note:**
You can also import the database variables from the labels. Just make sure to tick the option **Use database variables defined in the label file**.

If you do not want to manually import variables, use the **New Form Wizard**.

**Note:**
Avoid using the same variable names as are the names of the **internal variables** in the application, like Date, Time or Username.

---

Link Object with Variables

**METHOD 1**

1. Place a fixed object on the form.
2. Double click the object. The properties of the object open.
3. Go to the **Contents** tab.
4. Select the **Variable value** in the Contents combo box.
5. Select the appropriate variable from the list of variables.

**Note:**
If there are no variables in the list, click on the **New** button and create a new variable or import variables from the label. Then repeat the process from step 1.

6. Click on the **OK** button.
METHOD 2

1. Click on the small arrow button next to the object icon in the toolbox.
   A context menu will display.
2. Select the option **Use Existing Variable**.
3. Select the variable from the list.

**Note:**
If there are no variables in the list, click on the **New** button and create a new variable or import variables from the label. Then repeat the process from step 1.

4. Click on the form where you want to position the object.

---

**Print a Label Which File Name is Read from the Database**

1. Create new form.
2. Select the command Get variables from the Design menu.
3. Browse to one of the labels you want to print and click on it.
   The variables from the label will be imported on the form.

**Note:**
All labels that you want to print using the suggested approach must have defined the variables with the same name.

4. Select the option **Variables** in the Data menu.
5. Click on the **Add** button to define one local variable that will contain the name of the label file that should be opened.
   Name the variable **Label**.
6. Select the Database Access in the Data dialog box.
7. Click on the buttons **Wizard** to create a connection to a database that stores the label names. Select the option **I want a table object** in the database wizard.
8. Double click the table object.
   Table properties will open.
9. Go to the **Columns** tab.
10. Make sure the variable **Label** is linked to the database field containing the name of the label.
11. Click on the **OK** button.
12. Place a button object on the form.
13. Double click the button object.
14. Go to the **Actions** tab.
15. Click on the **Edit** button.
16. Insert the action **Open label** to the right pane.
17. In the action properties select the option **Variable label file name**.
18. Select the variable **Label**.
19. Click on the **OK** button.
20. Define the rest of the actions for the button.
21. Click **OK** to return to the form.

When you select a record in the table, the label name will be saved in the variable **Label** and the appropriate label will be opened and printed.

---

**Print Two or More Different Labels**

If you want to print more labels from single click on the Print button, do the following:

1. Make sure you are in the Design mode.
2. Double-click on the Print button on the form.
3. Go to the **Actions** tab.
4. Click on the **Edit** button to open Actions Editor window.
5. Define another command **Open label** and select the other label file you want to print.
6. Define the command **Print label** under the second Open label command.
7. Click on the **OK** button to close the Actions Editor window.
8. Click on the **OK** to return to the form.

When the user runs the form and clicks on the Print button, each of the **Open label** commands will print separate label file.

---

**Quickly Design and Test the Form**

1. Select the command **New Form Wizard** from the File menu and complete the wizard.
   The result will be working form file based on the selected label file.
2. Select the command **Run** in the Design menu to start the form.

**Note:**
You can also click on the **Run** button to start the form.

3. Enter all the necessary data values and then click on the **Print** button to start printing labels.

**Note:** In addition to the usual use of `<Tab>` button to skip between fields, `<MadCap:variable name="Variables.Module-Form" />` it is possible to use the `<Enter>` key which performs the same function.
Change the Focus of the Objects

Every object that is currently active in the running form has the focus. If the object has the focus, you can use it. You can type in the data in the edit field. You can select pre-defined data from combo box. You can press Enter to execute the actions in the button.

All objects in the form are organized in the tab order. This is the object order of appearance in which the focus moves. Focus moves from the first object in the tab order list to the last one, then the focus is moved to the first object and the cycle repeats.

To change the focus of the objects during the form design, you have the following options:

**Pre-define the tab order.**

1. Select **Design -> Tab Order.**
2. Use the Up and Down arrow buttons to change the object order of appearance. The top object is the first in the tab order. The tab order is saved with the form.

**Note:** If you do not change the tab order, the default tab order is the order in which you put the objects on the form.

3. To change the object focus while the form is running press the Tab (tabulator) key. Each press of the Tab key will move the focus to the next object in tab order.

**Use the action "Move Focus to Object" in the button.**

1. Open the properties of the Button object.
2. Go to the **Actions** tab.
3. Click the **Edit** button.
4. Define the action **Move focus to Object**.

**Note:** If you do not see the action **Move focus to Object** listed, click the Advanced button to show all available actions.

5. In the action you have two available options:
   - Move the focus to the first object in tab order.
   - Move the focus to some particular pre-defined object.

**Note:** You can also use the action **Move focus to Object** in the automatic events (File -> Form Properties -> Events).
Change the Screen Position of the Running Form

When you run the form that you have created, by default it will run in the maximized mode on the default display. You do not have to run the form in the maximized mode; you can center the form on the desktop or current screen.

Do the following:

1. Select **File -> Form Properties**.
2. Go to **Appearance** tab.
3. Select the option **Normal**.
   - Now you can set the form dimensions, centering and offsets on your own.
4. Select the appropriate option for the Position and Size section.

Set the Tab Order in Which the Data is Entered

1. Select **Design -> Tab order**.
2. Select the order of the objects, click Up and Down arrows to adjust the tab order.

**Note:** You can also use keyboard shortcuts Alt + Up and Alt + Down to change the position of objects in the list.

3. Click on the **OK** button.
4. Select **Run** in the Design menu to start the form.
5. Test the behavior of the tab order. As the user presses the <Tab> key, the focus advances from one object to the other. The next object in the tab order is selected and becomes active.

Use Data from Database

1. Select the command **Database Access** in the Data menu.
2. Click on the Wizard button and follow on-screen instructions.
   - The database table will be defined on the label.
   - Database fields will be linked to the specified objects.

Once the database is available in the application, its fields can be used with any form object.

It is possible to use variables in SQL as parameters. The parameters in SQL are preceded by a semicolon (`:param_name`). Variables used as parameters must have a default value that corresponds to SQL (a variable used as a parameter in place of the Date Field must...
Designing Forms

have a default value that corresponds to a date). DO NOT change the default values of variables used in SQL after defining SQL. It is however possible, to connect those variables to an EditBox, creating a form that knows how to filter data.

Use Distributed Printing

The application provides additional printing method. Apart from the regular printing to the local or network-connected printers it is possible to enable true network printing. In this mode the application does not connect to the print engine directly to print the labels but creates a batch command .JOB file, containing necessary commands to describe the current print operation.

The .JOB file can then be either dropped on a specified network folder or sent to the server application over TCP/IP network protocol.

Design Form for Mobile Devices

NiceLabel Suite edition is available with the license for Pocket edition of the labeling software, print-only edition for Windows Mobile devices. You can define the labels and forms on your desktop computer and then export them to your Mobile device.

To create a form suitable for Mobile device, to the following:

1. If you use the New Form Wizard to create a form: When you are prompted for system platform selection make sure to select the option Mobile Windows application and then select the appropriate platform from the list. The platform must match your Mobile device specifications.

2. If you create the form manually, open File -> Form Properties -> Window tab and select appropriate platform from the list. The platform 'Windows' is desktop Windows application, all other options are for Mobile windows applications.

Once you are finished with the form design, you must to export the form and other files (labels, graphics, databases) to the Mobile device. Do the following:

1. Make sure the following is accomplished:
   - The selected platform for the form is for the Windows Mobile device.
   - The form file is saved on disk.
   - ActiveSync is installed on the computer.
   - Your Mobile device is in sync with the desktop computer.
   - Your labels are optimally designed for the selected thermal printer.
Note: Not all label design features are available when you design the label for Mobile devices. Make sure your label does not use some incompatible feature. To verify the compliance label design use the command File -> Export -> Export to Pocket PC inside the label designer and see the possible error messages on-screen.

2. Select the command File -> Save to Pocket PC.
3. Follow on-screen instructions in the Wizard.
Automating the Software

Command Line Parameters

You can use the command line parameters to pass advanced commands to the form designer when the application starts.

There are actually two form applications available (two EXE files). One is form designer, one is run-time module that executes the designed form.

<Program_Name>.EXE [file_name] [options]

**For designer:**
The Program_Name is C:\Program Files\EuroPlus\NiceLabel 5\bin\nform5.exe

[file_name] Represents the full path and name of the form file to open.

[parameter] can be the following:

| /off2xff | If you start form designer with this parameter, you can convert the form files from previous versions of the software (text .OFF file format) to newer version (XML .XFF file format).
|          | **Single file conversion**
|          | If the application is run with "filename.off /off2xff" parameters then form designer will convert file filename.off to the new format with the name filename.xff.
|          | **Note:** If the file filename.xff already exists it will be overwritten without a question.
|          | **Multiple file conversions**
|          | If the application is run with "foldername /off2xff" parameters then form designer will convert all files with the .off extension in the specified folder foldername to the new format with the .xff extension.

**For run-time module:**
The Program_Name is C:\Program Files\EuroPlus\NiceLabel 5\bin\nformrt5.exe

[file_name] Represents the full path and name of the form file to start. In this case the user does not see the form design option. He can use the form only.
[parameter] Run-time module does not have any command-line parameters.
Technical Support

Online Support

You can find the latest builds, updates, workarounds for problems and Frequently Asked Questions (FAQ) on the product web site at www.nicelabel.com. If you cannot solve the problem on your own, please contact your local vendor or representative offices listed in the topic Contact Information.

For more information please refer to:

- Support FAQ: http://kb.nicelabel.com
- NiceLabel FAQ: www.nicelabel.com/Learning-center/Sales-FAQ
- NiceLabel Tutorials: www.nicelabel.com/Learning-center/Tutorials
- NiceLabel Forums: forums.nicelabel.com

Contact Information

Head Office

Euro Plus d.o.o.
Poslovna cona A 2
SI-4208 Šenčur
Slovenia
Tel: +386 4 280 50 00
Fax: +386 4 233 11 48
support@nicelabel.com
www.nicelabel.com

North American Office

Niceware International, LLC.
200 South Executive Drive, Suite 200
Brookfield, Wisconsin 53005
USA
Tel: (888) 894-NICE (6423)
Fax: (262) 784-2495
support@nicewareintl.com
www.nicewareintl.com
Technical Support

German Office
NiceLabel Germany GMBH
Liebknechtstr. 29
63179 Obertshausen
Germany
Tel: +49 (0)6104 405 400
support@nicelabel.de
www.nicelabel.de

China Office
GARDEN BUSINESS CENTER
Julu Rd. 889, Building 23
Office 8311
Shanghai 200040, PR China
Tel: +21-62490371
Fax: +21-62490372
support@nicelabel.cn
www.nicelabel.cn