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System Requirements

System Requirements
NiceLabel Designers
The information in this topic is valid for the following products: NiceLabel Designer Express, NiceLabel Designer Standard,
NiceLabel Designer Pro, NiceLabel Print-only, NiceLabel PowerForms Desktop, NiceLabel PowerForms Runtime, NiceLabel
Desktop Suite, NiceLabel Desktop Suite Runtime.
l
l
l
l

l

CPU: Intel or compatible x86 family processor
Memory: 256 MB or more RAM
Hard drive: 1 GB of available disk space
Operating system: 32-bit or 64-bit Windows operating systems: Windows XP Service Pack 3, Windows Vista, Windows
7, Windows 8, Windows 8.1, Windows 10, Windows Server 2003, Windows Server 2003 R2, Windows Server 2008,
Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2
Display: 1024×768 or higher resolution monitor

NiceLabel Multi-user Software
The information in this topic is valid for the following products: NiceLabel PowerForms Multi-user, NiceLabel Desktop Suite
Multi-user and NiceLabel Desktop Suite Runtime.
l
l
l

l

l

All requirements for the NiceLabel Designers
Network interface card in each workstation
Computer acting as a file share server (any operating system --even non-Windows-- that allows file sharing with Windows systems)
Each client must have granted full access (read, write, delete) to the NiceLabel's System folder (shared NiceLabel files
on the server) on the file share server
Local Area Network (LAN)
NOTE: Running Multi-user edition over WAN or Internet is not supported. For more information see NiceLabel
Control Center products.

NiceLabel Automation Easy
l
l
l
l

l
l
l
l
l
l

CPU: Intel or compatible x86 family processor
Memory: 512 MB or more RAM
Hard drive: 1 GB of available disk space
Operating system: One of the 32-bit or 64-bit Windows operating systems Windows XP Service Pack 3, Windows Vista,
Windows 7, Windows 8, Windows 8.1, Windows 10, Windows Server 2003, Windows Server 2003 R2, Windows
Server 2008, Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2
Microsoft .NET Framework Version 4.0
Display: 1024×768 or higher resolution monitor
Label Designer:
Recommended: NiceLabel Designer Pro or NiceLabel PowerForms V6.0 or higher
Minimum: NiceLabel Pro V5.4
Recommended printer drivers: NiceLabel printer drivers V5.1 or higher
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Installing Designers
Installing Single-user Software
The instructions from this topic are valid for all single-user NiceLabel designer products, such as NiceLabel Designer Express,
NiceLabel Designer Standard, NiceLabel Designer Pro, NiceLabel PowerForms Desktop and NiceLabel Desktop Suite.
Use the installation wizard to install the labeling software on your desktop PC. To install the labeling software, do the following:
1. Insert the product DVD in your DVD drive. An installation window will open automatically.
NOTE: If the installation wizard does not start automatically, double-click on START.EXE on the DVD.

2. Click on Install NiceLabel product. A new window will open, showing all available software editions.

3. Click on the NiceLabel product you want to install.

4. Follow-on-screen instructions.
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Installing NiceLabel Desktop Suite
NiceLabel Desktop Suite is a bundle of NiceLabel PowerForms Desktop and NiceLabel Automation Easy. You have to
install both products.
To install NiceLabel Desktop Suite from the NiceLabel DVD, do the following:
1. Insert the product DVD in your DVD drive. An installation window will open automatically.
NOTE: If the installation wizard does not start automatically, double-click on START.EXE on the DVD.

2. Click on Install NiceLabel product. A new window will open, showing all available software editions.

3. Click on NiceLabel PowerForms Desktop.

4. Follow-on-screen instructions to install the software.
5. Click on NiceLabel Automation Easy.

5

Installing Designers

6. Follow-on-screen instructions to install the software.
To install NiceLabel Desktop Suite from the self-extractable EXE file you have downloaded from NiceLabel web page, do the
following:
1. Start the bundle installer NiceLabelDesktopSuite6.EXE.
2. Click on Install PowerForms Desktop.

3. Follow on-screen instructions.
4. Click on Install NiceLabel Automation Easy.
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5. Follow on-screen instructions.

Installing the Multi-user Software
Introduction
The Multi-user software consists of two parts: the server part and the client part.
You must first install the labeling software on the server computer and share the files to the clients. Then you can install the
labeling software client on the workstation. You can run the client installation from the server or from the product DVD. Both, the
server and the client must be accessible in the same Local Area Network (LAN). You should select a server and disk share that is
visible to all workstations in the domain where you intend to use the software.
WARNING: The Multi-user edition does not support connections over WAN, internet or other long-distance
connections. In this case, see NiceLabel Control Center products.

Installing the Software on the Server
Please follow these steps to install the labeling software on the server computer:
1. Make sure that the folder on your server where you want to install the labeling software provides full access admission.
2. Put the NiceLabel DVD in your DVD-ROM drive. An installation window will open automatically.
NOTE: If the installation wizard does not start automatically, go to the root folder of your product DVD and
double-click on the file START.EXE.
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3. Click on Install NiceLabel product. A new window will open display all available software editions.

4. Click on NiceLabel PowerForms Multi-user.

5. Follow on-screen instructions.
6. When prompted to Network primary location, type in the network location where you will install the server part and click
Next.
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NOTE: Make sure you are using UNC syntax when referring to the network location. Use the syntax
\\server\share and not the syntax with the mapped drive, such as G:\share.
7. You can enter the location of the secondary server that will take over when primary server fails. If you have a computer
to act as a secondary license server, enter the UNC path to the appropriate folder. "Using Primary and Secondary
Server" on page 42.
NOTE: If unsure, leave the secondary server disabled. The secondary server is optional.

8. You can create an MSI installation file if you want to automatically deploy the client software on workstations using the
Active Directory group policy. You can use the MSI file for silent and unattended installation of software. "Installing the
Multi-user Client in the Unattended Mode with Group Policy" on the next page.
NOTE: If unsure, skip this optional step.

9. Click on the Next button to finish the installation.
NOTE: You must select a server and disk share that is visible to all workstations in the domain where you
intend to use the software.
10. After the installation completes, you can enable the Run Workstation Install option and install the NiceLabel client on
the server computer as well. This is an optional step. If needed, you can install the client at any later time.

Installing the Client Interactively
There are a few methods to install the labeling software Multi-user client on the workstation:
l

Installing the client from the network share (the recommended method).
In this case you will ensure that every workstation has the same version of NiceLabel client installed. If you follow this
installation method, the client will automatically activate with the license, no manually activation procedure is necessary.
To install the software client by running the installation file from the server, do the following:
1. Open Windows Explorer.
2. Browse to the labeling software server computer in Network.
3. Browse to the folder where the NiceLabel software is installed on the server.
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4. Double click on the client installation file (NiceLabelDesignerProPowerForms6.EXE).
5. Follow on-screen instructions. For more information, "Installing Single-user Software" on page 4.
NOTE: The client installed on any workstation must have full access (read, write, delete) to the
System sub folder on the server computer.
l

Installing the client from the DVD.
Actually, the client in the Multi-user product is a single-user software NiceLabel PowerForms Desktop.
To install the client from the DVD, "Installing Single-user Software" on page 4.

Installing the Multi-user Client in the Unattended Mode with Group Policy
In this case the client installs automatically with a directive from Windows Active Directory. The "Group Policy" allows the
administrators to deploy the software without any user intervention on the workstations. When the group policy is in place the
client can install automatically when the user logs into the system the next time, or the installation of the client can be forced at
any time.
To take advantage of the unattended installation mode, you need to prepare the labeling software installation as MSI package
that is compatible with the group policy.
To create the .MSI installation package, do the following:
1. Start the installation of the NiceLabel PowerForms Multi-user.
2. Follow the on-screen instructions until you reach the step Group Policy Installation. By default the group policy
installation is disabled.
3. Enable the option Create MSI file for Group Policy deployment.
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4. Select the folder where to save the .MSI file.
5. Click Next.
For more information about the group policy and remote software installation, see articles, such as How to use Group Policy
to remotely install software in Windows Server 2008 and in Windows Server 2003 on Microsoft Web site.

Notes for Installation on Windows Remote Desktop Services (Terminal Services) and Citrix
Environment
Before you start with the Multi-user installation on the Windows Terminal Services or Citrix Metaframe, read the White Paper
explaining how to use the labeling software with Windows Terminal Services and Citrix Metaframe. The White Paper is available
on product website.

Installing NiceLabel Desktop Suite Multi-user
NiceLabel Desktop Suite Multi-user is a bundle of NiceLabel PowerForms Multi-user and NiceLabel Automation Easy.
You have to install both products.
To install NiceLabel Desktop Suite from the NiceLabel DVD, do the following:
1. Install NiceLabel PowerForms Multi-user per instructions at the beginning of this chapter.
2. Switch back to the autorun application started from NiceLabel DVD. You can re-insert NiceLabel DVD to automatically
run it.
NOTE: If the installation wizard does not start automatically, go to the root folder of your product DVD and
double-click on the file START.EXE.
3. Click on Install NiceLabel product. A new window will open, showing all available software editions.
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4. Click on NiceLabel Automation Easy.

5. Follow-on-screen instructions.
To install NiceLabel Desktop Suite from the self-extractable EXE file you have downloaded from NiceLabel web page, do the
following:
1. Start the bundle installer NiceLabelDesktopSuiteMultiUser6.EXE.
2. Click on Install PowerForms Multi-user.
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3. Follow on-screen prompts. Also refer to the information at the beginning of this chapter.
4. Click on Install NiceLabel Automation Easy.

5. Follow on-screen instructions.

Install Command-line Parameters
NiceLabel installer can be controlled with the command-line parameters.
NOTE: Make sure to use the upper-case syntax exactly as shown. Most of the parameters are used without the
leading slash, there are two exceptions /s (for silent install) and /l (for logging).
Parameter

Description

/s

Silent install. No dialog boxes are displayed. The installer executes in the
background.

/l="folder_and_file_name"

Logging the installation process in the provided file name. Make sure the user
account performing the installation has the access permissions to the folder.
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ALLUSERS=1

This parameter must be set when installing a .MSI with the privileges of the
Local System user account. You must set this parameter for the installer to add
NiceLabel to the list of installed software in Control Panel>Add or remove programs. This allows any other privileged user to have access to add/remove feature.

DISABLEANALYTICSSUPPORT

When this parameter is added the, the installer will disable the analytics support. By default, the user participates in the anonymous analytics reporting.

EDITION_PRO=TRUE

This parameter forces the installation of NiceLabel Designer Pro. By default,
the user is prompted for the product to install.

EDITION_POWERFORMS=TRUE

This parameter forces the installation of NiceLabel PowerForms Desktop. By
default, the user is prompted for the product to install.

TARGETDIR="folder_name"

Overriding the default installation folder.

PRIMARYSERVER=\\<server>\<share>

Specifying the location of the primary licensing server in case of NiceLabel
PowerForms Multi-user license. This will automatically activate the client, so
the user does not have to do it later.

SECONDARYSERVER=\\<server>\<share> Specifying the location of the secondary licensing server in case of NiceLabel
PowerForms Multi-user license.
Silent Uninstall
NiceLabelDesignerProPowerForms6.exe /s MODIFY=FALSE REMOVE=TRUE UNINSTALL=YES
Logging the installation
NiceLabelDesignerProPowerForms6.exe /l="C:\temp\InstallLog.txt"
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Installing Upgrades
Installing Single-user Upgrades
Introduction
You can upgrade the labeling software in the following ways:
l
l
l

Minor version upgrade - within one version, for example from 6.0 to 6.3.
Major version upgrade - from an older version to the most current one (major version upgrade), for example 5.0 to 6.3.
Software edition upgrade - software type upgrade, for example NiceLabel Designer Express to a more advanced edition like NiceLabel Designer Pro.

Before starting the upgrade, do the following:
l

l

Backup your labeling files, including your labels, forms, and system folder (see System folder in the respective product
folder in c:\ProgramData\EuroPlus).
Do not remove the existing version from your PC.

Installing Minor Version Upgrade
In a software minor version upgrade, you upgrade an older minor version, for example 6.0, to the latest version of 6.X.
Do the following:
1. Close the labeling software on your PC.
2. Start the installation of the new version of the same NiceLabel product that you currently have.
3. The installer of a new version will detect the old version. It will remove it (keeping all necessary data) and install a new
version in the same folder, replacing the old one.
4. Follow the prompts.
5. The new version will re-use the license from the old version.

Installing Major Version Upgrade
In a labeling software major version upgrade, you upgrade an older version, for example 5.X, to the latest version of 6.X.
Do the following:
1. Close the labeling software on your PC.
2. Start the installation of the new version of the same NiceLabel product that you currently have.
3. The installer of a new version will install it next to the old version. You will have NiceLabel software of both versions
installed.
4. Follow the prompts.
5. You will have to activate the new version.
NOTE: Activate the new product of the labeling software with the information provided in your upgrade package.
"Activating Single-user Upgrades" on page 28.

Installing Edition Upgrade
An edition upgrade is an upgrade to a more powerful software edition.
Do the following:
1. Close the labeling software on your PC.
2. Start the installation of the new NiceLabel product.
3. Follow on-screen information. "Installing Single-user Software" on page 4.
NOTE: Activate the new product of the labeling software with the information provided in your upgrade package.
"Activating Single-user Upgrades" on page 28.
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Installing Multi-user Upgrades
Introduction
You can upgrade the Multi-user edition in the following ways:
l

l

Upgrade software within one version (minor version upgrade), for example from 6.0 to 6.3.
Upgrade software version from an older version to the most current one (major version upgrade), for example 5.1 to
6.3.

Before starting the upgrade, do the following:
l

Backup your labeling files, including your labels, forms, and system folder (see System folder in the respective product
folder in c:\ProgramData\EuroPlus).

l

Do not remove the existing version from your server and workstations.

l

Make sure all clients have logged off before you install the Multi-user upgrade.

Installing Minor Version Multi-user Upgrade
In a minor version Multi-user upgrade, you upgrade an older minor version Multi-user, for example 6.0, to the latest version of
6.X.
Do the following:
1. Close the labeling software and any other running software on your server and workstations.
2. Put the product DVD in your DVD-ROM drive on any computer with a labeling software client installed.
3. Install the new version on the server computer. Follow the same instructions as for the first-time installation. "Installing
the Multi-user Software" on page 7.
NOTE: Make sure to select the SAME shared folder on the server as for the first installation. The files will be
overwritten with the latest version.
4. Install the new version of NiceLabel client on all workstations. Follow the same instructions as for first-time installation.
NOTE: For more information for server or client installation, "Installing the Multi-user Software" on page 7

Installing Major Version Multi-user Upgrade
In a major version Multi-user upgrade, you upgrade an older Multi-user version, for example 5.X, to the latest version 6.X.
Do the following:
1. Close the labeling software and any other running software on your server and workstations.
2. Put the product DVD in your DVD-ROM drive on any computer with a labeling software client installed.
3. Install the new version on the same server computer using the same installation folder. Follow the same instructions as
for the first-time installation. "Installing the Multi-user Software" on page 7.
NOTE: Make sure to select the SAME shared folder on the server as for the first installation. The files will be
overwritten with the latest version.
4. Install the new version of NiceLabel client on all workstations. Follow the same instructions as for first-time installation.
NOTE: For more information for server or client installation, "Installing the Multi-user Software" on page 7
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Installing Printer Drivers
NOTE: For a detailed instructions on how to install the printer driver, please refer to the document NiceLabel Printer
Drivers Installation Guide available for download from NiceLabel web.
You can use the labeling software to design and print labels to standard office printers, such as laser, ink jet or dot matrix, to
professional output devices, such as thermal label printers or other marking devices (inscribing laser, high-speed ink jet). For
any printer you have, you first have to install the appropriate printer driver before you can use it. NiceLabel software is
accompanied with the printer drivers all major thermal printer brands.

Printer Driver Installation Using the Printer Installation Wizard
1. Put the NiceLabel DVD in your DVD-ROM drive. The main installation application will start automatically.
NOTE: If the installation wizard does not start automatically, double-click on START.EXE on the DVD.

2. Click on Install NiceLabel Printer Drivers. The printer installation wizard will start.

3. Follow on-screen instructions.
4. Select your printer from the list. Click the Next button.
5. Select the port where you have connected your printer and click the Finish button.
NOTE: If you have downloaded the installation for NiceLabel printer drivers from the product web site, run the
downloaded executable file and follow on-screen instructions.

Printer Driver Installation within Software Installation
To continue installing the NiceLabel printer driver after setup has finished the labeling software installation, do the following:
1. Select the option Install printer driver.
2. Click the Finish button.
3. The Printer Installation Wizard will open.
4. Select your printer from the list. Click the Next button.
5. Select the port where you have connected your printer and click on the Finish button.
NOTE: This type of printer installation is available only when running installation from the product DVD.
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Printer Driver Installation Using the Windows Add Printer Wizard
1. In Control Panel, select View devices and printers to open Devices and printers.
2. Click Add a printer.

3. Follow the Add Printer Wizard prompts. The actual steps vary depending on the version of your Windows operating
system. Click on Have disk button in the step where you can select printer manufacturer and model.
4. Put the NiceLabel DVD in your DVD-ROM drive and browse to the folder Drivers.
5. Select the folder of your printer name. You will see the list of all available printer models of the selected manufacturer.
6. Select your model, click Next and finish the installation.
NOTE: If you have downloaded the NiceLabel printer drivers from the Web site and extracted them to disk, you can
browse for the files in c:\NiceLabel Printer Drivers.
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Activating Software
The following activation instructions are valid for single-user and multi-user editions.
You have to activate the software if you want to use it. The software will run in trial mode for 30 days after the installation and
then switch into limited demo mode.
There are the following types of the software activation:
l
l

l

Single-user Hardware key activation. The USB hardware key is used to activate the software.
Single-user Software key activation. The Software Key number is a sequence of 25 characters and is used to activate the software. Internet connection is required for activation.
Multi-user Software key activation. You can activate Multi-user products the same way as single-user with software key. Internet connection is required for activation.

Activating Single-user Software
The information in this topic is valid for the following products: NiceLabel Designer Express, NiceLabel Designer Standard,
NiceLabel Designer Pro, NiceLabel Print-only, NiceLabel PowerForms Desktop, NiceLabel PowerForms Runtime, NiceLabel
Desktop Suite, NiceLabel Desktop Suite Runtime.

Activating Software with a Software Key
You can activate the labeling software automatically through the Activation Server (recommended) or manually through the
Activation Web site.
Before you start the activation process of the labeling software, get familiar with the following terminology:
l
l

l

Key number: The sequence of 25 characters provided with the labeling software.
Registration number: Unique number generated during the activation process. The registration number validates
the entered software key.
Activation code: Issued on the labeling activation Web site. The activation code activates the labeling software on
your computer.

To activate the single-user software, do the following:
1. Follow the installation instructions to install the NiceLabel software.
2. Start the NiceLabel designer. It will run in the trial or demo mode.
3. Click on the button Enter license key.

4. Select Single-user Software Key.
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5. Click Next.
6. Enter the required customer information and the key number.
7. Click the Next button. The window Manage License – Activation Code will open.
8. To activate the software automatically, click on the link Automatic to activation (recommended).

If you don't have the access to the Internet on the computer, where you have installed the software, you will have to use other
activation options. "Activation without Internet Access" on page 26.

Activating Software with a Hardware Key (Single-user)
To activate the labeling software using a USB key, do the following:
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1. Start the NiceLabel designer. It will run in the trial or demo mode.
2. Click on the button Enter license key.

3. Select Hardware Key.

4. Plug the USB key into an available USB port.
If the computer has the Internet access, the necessary driver will be downloaded from the Windows Update.
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If you don't have the connection to the Internet on your computer, install the hardware key driver from the NiceLabel
DVD, or download it from the NiceLabel Web site (look for "Device driver for the hardware key - HASP").
Do the following:
1. On the NiceLabel DVD, open the folder:
Utility\USB License Key Driver\GUI installer
or
Extract the downloaded ZIP file.
2. Run the application HASPUserSetup.exe and follow on-screen instructions.
There is also a command-line utility to install the HASP driver on the DVD and download page, should you have
troubles with the GUI utility.
5. Click Next.
6. The hardware key will be detected and the product level displayed on screen.

7. Click on the Finish button and labeling software will be activated.
NOTE: You can only activate some Single-user editions with a hardware key, the Multi-user editions are software key
only.

22

Activating Software

Notes on Activating NiceLabel Desktop Suite
NiceLabel Desktop Suite is a bundle of NiceLabel PowerForms Desktop and NiceLabel Automation Easy and is available
with two license keys.
l
l

One license key is used to activate NiceLabel PowerForms Desktop.
The other license key is used to activate NiceLabel Automation Easy.

To activate NiceLabel PowerForms Desktop , "Activating Software with a Software Key" on page 19.
To activate NiceLabel Automation Easy, do the following:
1. Run NiceLabel Automation Builder.
2. Select File>Tools>Manage License. The Activation Wizard will start.
3. For the activation method select Single User Software Key.

4. Click Next and follow on-screen instructions.
If you don't have the access to the Internet on the computer, where you have installed the software, you will have to use other
activation options. "Activation without Internet Access" on page 26.

Activating Multi-user Software
The information in this topic is valid for the following products: NiceLabel PowerForms Multi-user, NiceLabel Desktop Suite
Multi-user, NiceLabel Desktop Suite Runtime, and License Packs.

Activating Multi-user Edition
You can activate the Multi-user edition of the labeling software with a 25-character software key.
Before you start the activation process , get familiar with the following terminology:
l
l

l

Key number: The sequence of 25 characters provided with the labeling software.
Registration number: Unique number generated during the activation process. The registration number validates
the entered software key.
Activation code: Issued on the activation Web site. The activation code activates the labeling software on your computer.

To activate the multi-user software, do the following:
1. Follow the installation instructions to install the server part and the client(s).
2. Run the client on any workstation. It will run in the trial or demo mode.
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3. Click on the button Enter license key.

4. Select Multi-user Software Key.

5. Click Next.
6. Enter the primary network location path. Enter the same path as the one entered during the installation of the server
part and click Next.
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NOTE: Make sure you are using UNC syntax when referring to the network location. Use the syntax
\\server\share\folder and not the syntax with the mapped drive, such as W:\share\folder.
7. Click Next.
8. Enter the required customer information and the key number.
9. Click Next.
10. To activate the software automatically, click on the link Automatic activation (recommended).

11. Click on the Next button and follow the prompts to complete the activation process.
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12. If you have installed the clients from the server, all clients will know where the server is and will automatically get the
license, when you start them.
If you have installed the clients from the DVD, you will have to activate them upon first start up. In this case, follow the
steps 2-5 above.
If you don't have the access to the Internet on the computer, where you have installed the software, you will have to use other
activation options. "Activation without Internet Access" below.

Notes on Activating NiceLabel Desktop Suite Multi-user
NiceLabel Desktop Suite is a bundle of NiceLabel PowerForms Multi-user and NiceLabel Automation Easy and is
available with one license keys.
To activate NiceLabel PowerForms Multi-user clientt, "Activating Multi-user Edition" on page 23.
To activate NiceLabel Automation Easy, do the following:
1. Run NiceLabel Automation Builder.
2. Select File>Tools>Manage License. The Activation Wizard will start.
3. For the activation method select Multi-user Software Key.
4. Click Next.
5. Enter the primary network location path. Enter the same path as the one entered during the installation of the server
part and click Next.
NOTE: Make sure you are using UNC syntax when referring to the network location. Use the syntax
\\server\share\folder and not the syntax with the mapped drive, such as W:\share\folder.
6. Click Finish.
NOTE: NiceLabel Automation Easy will use the same license as NiceLabel PowerForms clients.

Activation without Internet Access
If you don't have the access to the Internet on the computer, where you have installed the software, you will have to use other
activation options.
In this case, do the following:
1. Make sure to complete steps to open the Activation dialog box and enter the License Key.
2. Write down the Key number and the Registration number.
3. Write down the Internet activation Web address.
NOTE: You can also click the button Save Data and store the activation information to the text file. It will save
you some time as you do not have to write down the numbers.
4. Go to a computer with Internet access and open the activation Web site in the Internet browser.
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5. Enter the Key number and the Registration number. Enter other user information when prompted.
6. Click on the Activate button to retrieve the Activation code. Write it down.
7. Go back to the client computer where the window Manage License is still open.
8. Enter the Activation code.
9. Click on the Next button and follow the prompts to complete the activation process.
NOTE: If you do not have access to the Internet at all, please call the Technical Support for phone activation.
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Activating Upgrades
Activating Single-user Upgrades
The information in this topic is valid for the following products: NiceLabel Designer Express, NiceLabel Designer Standard,
NiceLabel Designer Pro, NiceLabel Print-only, NiceLabel PowerForms Desktop, NiceLabel PowerForms Runtime, NiceLabel
Desktop Suite, NiceLabel Desktop Suite Runtime.

Minor Version Upgrade
When you upgrade to a new minor version of the same edition, for example version 6.0 to version 6.3, the software will remain
activated. The installer will install the new version on top of the old version overwriting it and keeping the activation data.

Major Version Upgrade
When you upgrade to a new major version of the same edition, for example version 5.1 to version 6.3, you will have to activate
the new version. The new version does not override the existing one and installs in a separate folder. You can work with both the
old and new version at the same time.
Please follow the same instructions as for the first-time installation of the labeling software in the chapter Installing the
Software.
Summary of required steps:
1. Close running NiceLabel applications.
2. Do not remove the existing version of the NiceLabel software.
3. Install the new version of the same product you already have.
4. If your old version of the software is activated with a hardware key, plug it in.
5. Activate the new the version with the upgrade key number.
NOTE: To upgrade your software version 5.1 to version 6.X, you need to have available both the old 25-digit
serial number (for version 5.1) and the new 25-digit software key number (for version 6.x). Both keys are
required to activate your software upgrade. After the upgrade the old software key is deactivated.
To activate the new version, do the following:
1. Open the newly installed labeling software.
2. Click on the Manage License button. The Manage License window will open.
NOTE: If you activate the labeling software immediately after completing the installation, select Activate the
package and click on Next.
3. Select Single User Software Key and click on Next. A new Manage License window will open showing the key
license information of your old version of labeling software.
NOTE: If your old software came with a USB key, plug the key into an available port, select Hardware Key
and click on Next.
4. If your software is protected by a software key, select Manage current software key license and click on Next.
If your software is protected by a hardware key, select Manage current hardware key license and click on Next.
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5. In the Manage License – Manage software key license window, select Upgrade key license and click on Next.

6. In the Manage License – Upgrade code window, enter the Upgrade Key Number you received from your vendor.
7. Click on the Next button and follow the prompts to complete the activation process.
8. To activate the software automatically, click on the link Automatic activation (recommended).
If you don't have the access to the Internet on the computer, where you have installed the NiceLabel software, you will have to
use other activation options. "Activation without Internet Access" on page 32.
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Edition Upgrade
When you upgrade to a new product of the labeling software, for example from NiceLabel Designer Express to NiceLabel
Designer Pro, you keep the existing product on your computer and install and activate the new product. In this case, follow the
same instructions as for the first-time installation of the NiceLabel Software. "Installing Single-user Software" on page 4.
Summary of required steps:
1. Close all labeling software applications.
2. Keep the old software installed.
3. Install the new edition of the software.
4. Activate the new edition with the upgrade key number.
NOTE: To upgrade your software edition, you need to have available the old 25-digit serial number/ software key and
the new 25-digit software key number. Both keys are required to activate your upgrade. After the upgrade the old
software key is deactivated.

Activating Multi-user Upgrades
The information in this topic is valid for the following products: NiceLabel PowerForms Multi-user, NiceLabel Desktop Suite
Multi-user, NiceLabel Desktop Suite Runtime, and License Packs.

Minor Version Upgrade
When you upgrade to a new minor version of the same product, for example version 6.0 to version 6.3, the software will remain
activated. The installer will install the new version on top of the old version overwriting it and keeping the activation data.
NOTE: Make sure to install the server part in the same folder on the server that is currently used for the Multi-user
edition. You will not have to activate the server again. It will remain activated from the previously installed version.

Multi-user Major Version Upgrade
In a major version Multi-user upgrade, you upgrade an older Multi-user version, for example 5.X, to the latest version of 6.X.
In this case, you have installed a new multi-user version (server part) on top of the existing multi-user version (server part), and
you have installed a new client. The installation has overwritten the data in the System folder shared on the server, but has also
kept the data from the previous version, such as print history logging and global variables. For more information about the
installation, "Installing Multi-user Upgrades" on page 16
To activate the upgrade, to the following:
1. Start the new version of the NiceLabel designer.
2. In the Trial Mode dialog box, click Enter license key.
3. In Manage License dialog box, select Multi-use Software Key. Click Next.
4. Browse to the folder, where the server part of the NiceLabel multi-user installation is available. Click Next.
5. Enter the user information. Make sure to put the upgrade license key in the Key Number field. Click Next.
Enter the Old Key Number. This is the license key from the previous version that you want to upgrade.
NOTE: To upgrade your Multi-user version to new major version, you need to have available both the old 25digit serial number (for the old version) and the new 25-digit software key number (for the new version). Both
keys are required to activate your software upgrade. After the upgrade the old software key is deactivated and
cannot be used again.
6. To activate the software automatically, click on the link Automatic activation (recommended).
7. If you don't have the access to the Internet on the computer, where you have installed the NiceLabel software, you will
have to use other activation options. "Activation without Internet Access" on page 32.

Multi-user License Pack
With a Multi-user License Pack upgrade you can add user licenses to your current Multi-user edition in increments of 5, 10, 20 or
50 concurrent users. To add additional user licenses, you have to activate your Multi-user License Pack software key you have
received from your vendor.
To upgrade the Multi-user License Pack, do the following:
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1. Open the labeling software on your server computer or any client that has installed the software.
2. Select Help>Manage License.
3. Select Manage current Multi-user license and click Next.

4. In the Manage License – Manage Multi-user License window, select Add Multi-user licenses and click Next.

5. In the Manage License – License Pack Key Number window, enter the License Pack Key Number you have received
from your vendor.
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6. To activate the software automatically, click on the link Automatic activation (recommended).
If you don't have the access to the Internet on the computer, where you have installed the NiceLabel software, you will have to
use other activation options. "Activation without Internet Access" below.

Activation without Internet Access
If you don't have the access to the Internet on the computer, where you have installed the software, you will have to use other
activation options.
In this case, do the following:
1. Make sure to complete steps to open the Activation dialog box and enter the License Key.
2. Write down the Key number and the Registration number.
3. Write down the Internet activation Web address.
NOTE: You can also click the button Save Data and store the activation information to the text file. It will save
you some time as you do not have to write down the numbers.
4. Go to a computer with Internet access and open the activation Web site in the Internet browser.
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5. Enter the Key number and the Registration number. Enter other user information when prompted.
6. Click on the Activate button to retrieve the Activation code. Write it down.
7. Go back to the client computer where the window Manage License is still open.
8. Enter the Activation code.
9. Click on the Next button and follow the prompts to complete the activation process.
NOTE: If you do not have access to the Internet at all, please call the Technical Support for phone activation.
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Deactivating Software
When you use NiceLabel software activated with the software license key, you can deactivate the software and easily move the
license to other workstation. Deactivation works with the software key for Single-user and Multi-user products.
NOTE: The primary use of deactivation is move of the software to some other workstation. If you want to reinstall it, or
make the upgrade on the same workstation, you do not have to perform the deactivation.

Deactivating Single-user Software
To deactivate the single-user license, do the following:
1. Start NiceLabel designer.
2. Select Help>Manage License.
3. Select the option Manage current software key license .

4. Click Next.
5. Select the option Deactivate Software and follow on-screen instructions.
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NOTE: Make sure the computer can access the Internet. The license will be returned to the internet activation
server.
Another possibility of software deactivation is to uninstall the software. During the removal process you will be prompted
whether you also want to remove the license.
The single-user license has been deactivated and can be again activated on some other workstation.

Deactivating Multi-user Software
WARNING: Be careful when removing the Multi-user software key license. When you deactivate the Multi-user
software key, you will deactivate the activation of the server. All users of the software will have their licenses revoked
and their clients will switch to the demo mode.
If you do not need the locally installed NiceLabel client anymore, simply uninstall it. You don't have to deactivate it. In Multi-user
product the license is taken from the server upon each client start-up and is typically not stored locally.
NOTE: If you have activated the offline mode for the current client, then you have to disable offline mode before the
uninstall. For more information see "Offline Mode" on page 40.
To deactivate the multi-user license, do the following:
1. Start NiceLabel designer.
2. Select Help>Manage License.
3. Click the Open License Manager button.
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4. Click the Deactivate license button.

NOTE: Make sure the computer can access the Internet. The license will be returned to the internet activation
server.
The multi-user license has been deactivated and can be again activated on some other server.

Moving the Software License to Another Computer
The labeling software will run on each computer, where you have activated it. You can activate the software with a hardware
key, or software key (Single-user or Multi-user license).
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Moving Hardware Activation
To move the license to another computer when you have the USB hardware key, do the following:
1. Disconnect the USB hardware key from your computer.
2. Install the labeling software on the new computer. "Installing Single-user Software" on page 4
3. Activate the labeling software on the new computer. "Activating Single-user Software" on page 19.

Moving Software Activation
To move the license to another computer when you have the software key (25-character number), do the following:
1. Run NiceLabel designer on currently active computer.
2. Select Help>Manage License.
3. Enable the option Manage current software key license.
4. Click Next.
5. Select the option Deactivate License and click Finish. Selecting this option will remove the license from your
computer and store it back to the activation server.
NOTE: The computer must have access to the internet to be able to transfer the license back to the activation
server.
6. Install the software on the new computer. "Installing Single-user Software" on page 4.
7. Activate the software on the new computer. "Activating Single-user Software" on page 19.
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Registering the Software
At the end of the activation process, please fill out the registration form in the last step of the Product Activation process. If you
have the access to the internet, the product can be activated on-line. You can also print out the registration form and send or fax
it to the contact on the form.
Registration is not required but you should register the labeling software to receive the following benefits:
l
l

Free access to downloads and updates.
Free Technical Newsletter discussing product news.

To register the labeling software, do the following:
1. Start the label designer.
2. Select Help> Manage Registration.

3. Follow on-screen instructions.
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Online Self-help
You can find the latest builds, updates, workarounds for problems and Frequently Asked Questions (FAQ) on the product web
site at www.nicelabel.com.
For more information please refer to:
l

Knowledge base: http://kb.nicelabel.com

l

NiceLabel Support: http://www.nicelabel.com/support

l

NiceLabel Tutorials: www.nicelabel.com/Learning-center/Tutorials

l

NiceLabel Forums: forums.nicelabel.com

Contacting Technical Support
At some point, when you encounter a problem that you cannot solve by yourself, you may need to contact your support
representative for additional assistance
http://www.nicelabel.com/support/technical-support
NOTE: If you have a Service Maintenance Agreement (SMA), please contact the premium support as specified in the
agreement.
Before contacting support it would be very helpful, if you collected information about the problem, the computer and operating
system, you are running NiceLabel software on. You can use the following checklist.
Checklist
o

What happened? Write down exactly the error message that you get or make a screen shot of the error.

o

When was the error discovered for the first time?

o

What did you expect to happen?

o

Have you discovered the problem earlier?

o

Can the error be reproduced?

o

How often did the error occur?

o

Have you tried to use NiceLabel software this way earlier?

o

If your problem is coming and going, please describe circumstances and under what conditions the error appears.

o

Which version of NiceLabel software are you using?

o

Which version of NiceLabel was used to design the label?

o

Can you provide the files that you were using when the issue occurred (data files, configuration files, label files, etc.)?

o

Which printer are you using?

o

Which version of printer driver are you using?

o

Which operating system are you using? In which language?

o

Are you using firewall? Are all the required ports open?

o

Which version of Microsoft .NET framework is installed?

Troubleshooting
o

Software does not install
When the installer does not complete successfully despite following all rules for the prerequisites, enable the install log
file and send it to the regional Technical Support team.
To create the install log, do the following:
1. Press Windows key + R and type in cmd.
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2. In Command Prompt window, go to current user's temporary folder. Type in:
cd %temp%
3. In Command Prompt window, create an empty text file lblinstall.log. Type in:
type nul > lblinstall.log
4. Run the NiceLabel Automation install again. When the error displays again, close the installer.
5. Contact the regional Technical Support team and provide the lblinstall.log file.

Offline Mode
Introduction
The Multi-user edition depends on the network server that holds the licenses and common data used by all workstations. With
offline mode support you can run the client even, if it is not connected to the server. Half of all client licenses can be used as offline
licenses.
NOTE: The client running in the off-line mode will occupy one license. The off-line mode causes the license to be used
all times, even when the client is not running. After it quits it also does not release this license. The number of all
available licenses on the server is reduced by one.
Offline mode is useful in these scenarios:
l

l

In case of server or network failure, the whole system would fail. Off-line mode successfully copes with such situations
and clients are still able to operate, but some limitations apply.
Using the labeling software on laptops. In a company that has a Multi-user version installed some of the client installs
are done on notebooks. If the notebook is detached from the network, the labeling software will not operate. Off-line
mode successfully copes with this situation and enables you to use the Multi-user edition even without connection to the
network.

When the labeling software is started in off-line mode it will use local copy of the system files. When labeling software starts it will
determine if server is accessible. If it is, server files will be used. If not, local copy of system files will be used.

Enabling Offline Mode
To enable the offline mode and dedicate a license to a client, do the following:
1. Go to the workstation with NiceLabel client installed.
2. Start the application NiceLabel Pro.
3. Go to Help>Manage license.
4. Click Open License Manager.
5. Click Enable Offline Mode.

Limitations of the Multi-user Offline Mode
When the workstation is running in off line mode, there are few important issues that have to be considered. All functionality of
the labeling software is not available in the off-line mode.
Global
variables

Global variables cannot be used in off line mode. If the local copy of global variable and
a copy on another workstation or server would be used at the same time, the serial
numbers would be duplicated.

Log file

If you are using Microsoft Access log file, the log will be created, but will not be merged
with the main system log file when on-line mode is restored.
If you are using Text format of the log file and the path to the log file is not accessible,
the data will not be saved to log file.

Location of
labels,
database,
graphics, etc.

The availability of necessary label files is up to the user. The labeling software will not
duplicate these files.

Number of offline clients

The maximum number of off-line workstations is limited to half of the purchased
licenses.

Login
protection

Login protection and custom software user names are disabled in off-line mode

In Windows, you can enable off-line system accessibility directly in the Windows system
with the option Make Available Off-line.
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Lease period

Off-line client cannot occupy a software license for unlimited period of time. Maximum
lease period of every license is 15 days. If the client does not reconnect to the server in
on-line mode in this time period, its license will expire and be released to some other
client.
Lease period also considers the license used by a computer that will never login in online mode and normally release it (computer crashed beyond repair, computer got
stolen etc.). When lease period expires, the license will be returned to the group of
available licenses on the server.

Migrating Multi-user Software to New Server Computer
This top provides you with information what you have to pay a special attention to, if you want to migrate the Multi-user edition to
another server computer.
1. First prepare the new server computer. You will have to install the same version of the Multi-user edition to it from
scratch. "Installing the Multi-user Software" on page 7.
2. Deactivate the software on the first server. Select Help -> Manage License, then follow on-screen instructions.
During the deactivation process you must have the access to the internet. Your current Multi-user software key number
will be transferred back to the activation server.
NOTE: Internet access is required for license deactivation.

3. When the new server computer has labeling software properly installed and activated, you have to restore the previous
program settings and data files.
The files that need to be copied on the new server computer, if you want to retain the previous settings, are:
l
l
l
l
l

The software settings and list of users (SETTINGSDB.MDB)
Log file (LOGDATABASE.MDB)
Custom algorithm definition file (ALGO.DEF)
Stock database (STOCKDB.MDB)
Etc.

These files are located in the System folder of the server installation. When this step is completed, new software
installation should have the same settings as the old one.
NOTE: Make sure that no user is running labeling software at the time, when you copy files, so the files can be
overwritten.
The global variables are saved in the folder as specified by Variables folder in program preferences
(Tools>Options>General>Folders). The default folder is c:\ProgramData\EuroPlus\Variables and file name is
GLOBALS.TDB.
4. Migrate the label, form and database files to the new server computer. By default the labeling software uses the folder
structure with several sub folders, each for its own files:
l
l
l
l

Labels for label files (.LBL)
Forms for form files (.XFF)
Database for database files
Graphics for graphic files

Copy the contents of these folders to the new server to create duplicated file storage.

Recovering Locked Licenses
When the labeling software client connects to the server, one license gets occupied. If from some reason the client computer
stops responding, freezes or locks up and you are forces to reboot it, the license will still remain in use on the server.
To resolve the problem, do the following:
1. Restart the computer to normal operation.
2. Re-run NiceLabel client. The client will find its previous license on the server and will not occupy another one.
3. Close NiceLabel client.
4. The license will be released.

41

Support

NOTE: If the workstation that still occupies the license is not available any more, the license will be automatically
removed after 14 days.

Using Primary and Secondary Server
You should use the primary and secondary server whenever you strive to provide reliable label printing system. In this dualmode scenario the client licenses are stored on both servers at the same time. Whenever you start the client, it will check the
primary server and try to access the license. If the primary server is not available, the client will try to access the secondary server
and obtain the license from there.
The ability to store the license on primary and secondary server makes your label printing solution more robust.
NOTE:
- To install the licenses on two servers, make sure to tick the option Enable Secondary Server during the server
installation process and select also the name and shared folder of the second server.
- To enable the client to use the license from primary and secondary server, make sure to select path for the
Secondary (backup) network location as well, not only for the Primary network location.
The benefits using the secondary server mainly involve fail-save solution in case of primary server break-down. If the primary
server becomes inaccessible, the secondary server will take over its role.
l

You have to enable the secondary server during the installation of the server part.

l

The same licenses are available also on the secondary server.
NOTE: You need a single Multi-user Software Key to install the licenses on both servers. Just make sure to
provide paths to BOTH servers during the installation process. Do not make two separate server
installations.

l

Synchronization of files with user definitions and label stock files is done to the secondary server.
NOTE: The synchronization is performed from the primary to the secondary server only. When the primary
server is down and you continue using the labeling software, all the logging is done on the secondary server.
But the data is not synchronized back to the primary server.

l

The global variables are NOT synchronized. Each client has its own local file that stores the values of global variables
(by default in the System folder). The file name of the file storing values of global variables is GLOBALS.TDB.
To change the location of the file with global variables, do the following:
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1. Open Tools -> Options.
2. Select General -> Folders tab.
3. Select the appropriate folder for the Variables. Point to the location of the folder that stores the file
GLOBALS.TDB.
4. Click OK.
l

The log file is NOT synchronized.
To change the location of the log file, do the following:
1. Open Tools -> Options.
2. Select General -> Log file.
3. Look at Advanced section. and select the appropriate folder for the Local database location. Point to the
location of the folder that will store the log file.
NOTE: If you use Microsoft Access type of the log file, the file name is LOGDATABASE.MDB.

4. Click OK.

Using License Manager
The program License Manager is used to monitor and manage Multi-user licenses. License Manager displays the information of
the current client and also provides an overview of the total license occupation.
You can also use it to enable/disable off-line mode for workstations. Off-line mode enables selected workstations to function in
spite of the fact that the computer with licenses is not available or not accessible. It is used in environments where mobile label
printing is required or in events where server system failure would otherwise stop the label production.
Force Off-line Mode: The client will not check for the presence of the network server. The client will automatically start in the
off-line mode. When the license lease expires it will stop running and you must renew the license by switching off this option and
re-connecting to the network server.
NOTE: The off-line license expires after 14 days.

Application Settings Location: The software stores the setting in the System folder. By default, the System folder is
available on the network server and is shared among all clients. But you can also store the settings on the local workstation
where they are accessible to your client only.
The table at the bottom of the dialog box displays the consumption of the licenses. You can see all users that use the license.
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